aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-09-03 23:03:14 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-03 23:03:14 -0700
commit9bf3c31290e5e036f46700dd2d975024393ad211 (patch)
tree021668695c1698674c0a0a4cb5e5b99e8e7421d8 /app-admin
parentfix manifest (diff)
downloaddberkholz-9bf3c31290e5e036f46700dd2d975024393ad211.tar.gz
dberkholz-9bf3c31290e5e036f46700dd2d975024393ad211.tar.bz2
dberkholz-9bf3c31290e5e036f46700dd2d975024393ad211.zip
Add system-config-date
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-date/Manifest12
-rw-r--r--app-admin/system-config-date/files/1.8.5-gentooify.patch48
-rw-r--r--app-admin/system-config-date/files/digest-system-config-date-1.8.53
-rw-r--r--app-admin/system-config-date/system-config-date-1.8.5.ebuild44
4 files changed, 107 insertions, 0 deletions
diff --git a/app-admin/system-config-date/Manifest b/app-admin/system-config-date/Manifest
new file mode 100644
index 0000000..c2512c6
--- /dev/null
+++ b/app-admin/system-config-date/Manifest
@@ -0,0 +1,12 @@
+AUX 1.8.5-gentooify.patch 1711 RMD160 90699e6d038c66ddaaa2c53cc35e259f0a289b54 SHA1 56a8ffec89a2fcbcdb39ee23e13a6c94104e7d55 SHA256 17ab9ddc17e2f389f187143f7ea84882ac12419497aadf61db0dfb18e913bab2
+MD5 1909b714689b041d6d2d28b0622201a2 files/1.8.5-gentooify.patch 1711
+RMD160 90699e6d038c66ddaaa2c53cc35e259f0a289b54 files/1.8.5-gentooify.patch 1711
+SHA256 17ab9ddc17e2f389f187143f7ea84882ac12419497aadf61db0dfb18e913bab2 files/1.8.5-gentooify.patch 1711
+DIST system-config-date-1.8.5-1.src.rpm 592767 RMD160 302c14af813cd7a62a1c1027ce29722646ee921d SHA1 6abcd3efc7cc9276cfad03d218f8750e505f2e93 SHA256 4386526d059b8dda05377423a9d81e746a95d203511c7c2a4c257664621e9468
+EBUILD system-config-date-1.8.5.ebuild 1011 RMD160 81aaf914ac1a6ae37f00185ad02ceb80894f994e SHA1 4bbd8700a0fec6db756917bc6d2b4a70b7df6cf1 SHA256 4351dc22a4d5ddd9cc3b4186f742f50e241af6191012ab80022d852e805bd9b4
+MD5 685dc28c95b0628ff96761a51d507bca system-config-date-1.8.5.ebuild 1011
+RMD160 81aaf914ac1a6ae37f00185ad02ceb80894f994e system-config-date-1.8.5.ebuild 1011
+SHA256 4351dc22a4d5ddd9cc3b4186f742f50e241af6191012ab80022d852e805bd9b4 system-config-date-1.8.5.ebuild 1011
+MD5 7f206c6e86e35b81885701ad0cc9fa4c files/digest-system-config-date-1.8.5 283
+RMD160 bec7693e93662ff90e98253cd77e8543f8b8c329 files/digest-system-config-date-1.8.5 283
+SHA256 e82b3b644c6c47d47dc46a49a8138c4bb1e58b3506662ffcf53c3d0d207e0e0c files/digest-system-config-date-1.8.5 283
diff --git a/app-admin/system-config-date/files/1.8.5-gentooify.patch b/app-admin/system-config-date/files/1.8.5-gentooify.patch
new file mode 100644
index 0000000..d835b4c
--- /dev/null
+++ b/app-admin/system-config-date/files/1.8.5-gentooify.patch
@@ -0,0 +1,48 @@
+Index: dateBackend.py
+===================================================================
+RCS file: /usr/local/CVS/redhat-config-date/src/dateBackend.py,v
+retrieving revision 1.38
+diff -u -b -B -r1.38 dateBackend.py
+--- src/dateBackend.py 6 Mar 2006 15:35:42 -0000 1.38
++++ src/dateBackend.py 4 Sep 2006 05:53:46 -0000
+@@ -309,9 +309,9 @@
+
+ def startNtpService (self, wait):
+ if self.isNtpRunning() == 1:
+- fullPath = '/sbin/service ntpd restart > /dev/null'
++ fullPath = '/etc/init.d/ntpd restart > /dev/null'
+ else:
+- fullPath = '/sbin/service ntpd start > /dev/null'
++ fullPath = '/etc/init.d/ntpd start > /dev/null'
+ path = "/sbin/service"
+ args = [path, "ntpd", "restart"]
+
+@@ -319,16 +319,16 @@
+ return retval
+
+ def chkconfigOn(self):
+- path = ('/sbin/chkconfig --level 35 ntpd on')
++ path = ('/sbin/rc-update add ntpd default')
+ os.system (path)
+
+ def chkconfigOff(self):
+- path = ('/sbin/chkconfig --level 35 ntpd off')
++ path = ('/sbin/rc-update del ntpd')
+ os.system (path)
+
+ def stopNtpService (self):
+ if self.isNtpRunning() == 1:
+- path = ('/sbin/service ntpd stop > /dev/null')
++ path = ('/etc/init.d/ntpd stop > /dev/null')
+ os.system (path)
+ path = ('/sbin/chkconfig --level 35 ntpd off')
+ os.system (path)
+@@ -338,7 +338,7 @@
+ #The file doesn't exist, so return
+ return 0
+
+- command = ('/sbin/service ntpd status > /dev/null')
++ command = ('/etc/init.d/ntpd status > /dev/null')
+
+ result = os.system(command)
+
diff --git a/app-admin/system-config-date/files/digest-system-config-date-1.8.5 b/app-admin/system-config-date/files/digest-system-config-date-1.8.5
new file mode 100644
index 0000000..3b07506
--- /dev/null
+++ b/app-admin/system-config-date/files/digest-system-config-date-1.8.5
@@ -0,0 +1,3 @@
+MD5 dde216d83e6589c7381ee02161290848 system-config-date-1.8.5-1.src.rpm 592767
+RMD160 302c14af813cd7a62a1c1027ce29722646ee921d system-config-date-1.8.5-1.src.rpm 592767
+SHA256 4386526d059b8dda05377423a9d81e746a95d203511c7c2a4c257664621e9468 system-config-date-1.8.5-1.src.rpm 592767
diff --git a/app-admin/system-config-date/system-config-date-1.8.5.ebuild b/app-admin/system-config-date/system-config-date-1.8.5.ebuild
new file mode 100644
index 0000000..c00f030
--- /dev/null
+++ b/app-admin/system-config-date/system-config-date-1.8.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="A graphical interface for modifying system date and time"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-lang/python
+ net-misc/ntp
+ =dev-python/pygtk-2*
+ =dev-python/gnome-python-2*
+ sys-apps/usermode
+ dev-python/rhpl
+ dev-libs/newt
+ www-client/htmlview
+ x11-themes/hicolor-icon-theme"
+# app-admin/anaconda
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}