summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-08-20 14:15:17 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-08-20 14:15:17 +0000
commit634c39ef5454086299621f6a16f0b2e6009a10f1 (patch)
tree4620070b0db0932ad2d0b1e5241f5f41c9f6fe12
parentclean up (diff)
downloadmaintainer-634c39ef5454086299621f6a16f0b2e6009a10f1.tar.gz
maintainer-634c39ef5454086299621f6a16f0b2e6009a10f1.tar.bz2
maintainer-634c39ef5454086299621f6a16f0b2e6009a10f1.zip
Bump to pigment-0.3.7
* Added support to get Windows messages from the main loop. * Fixed unit test failing on 64 bits systems. * #267 : Failure in make check's PgmImage suite * #270 : Documentation for "released" signal in Drawable posibly wrong * pgm_viewport_set_message_filter() function * pgm_viewport_get_message_filter() function * PgmViewport::win32-message-event signal * PgmEventType::PGM_WIN32_MESSAGE enum field * PgmEventWin32Message struct * Added an OpenGL ES-CM 1.1 plugin. * Added support for the GLX texture-from-pixmap extension. * Added support to rotate drawables. * Highly improved Windows support. * Added support to rotate and reflect a canvas. * Added support for pressure events coming from touchscreens. * Added motion, entered and left signals to drawables. * Added support for mouse navigation events in the GStreamer image sink to handle DVD menu elements for instance. * Added support to transform positions from/to viewport, canvas or image coordinate spaces. * #8 : Spline interpolation * #63 : Hardware video overlay * #144 : Segfault while trying to open video * #145 : we can't use in pipeline drawable not added to a canvas * #178 : Enter/leave drawable signals * #208 : implicit animation leaks * #210 : examples on gutsy: `PGM_IS_VIEWPORT (viewport)' failed * #223 : Drawables "released" signal prototype inconsistency * #224 : [repository] The common/ external should be dropped * #235 : pigment locks when windows is out of screen * #239 : Bad error handling: exit(1) in main loop due to glXChooseFBConf... * #244 : support for GLX_EXT_texture_from_pixmap in OpenGL on X11 * #245 : Rotation and reflection of the canvas * #248 : C++ reserved keywords used as structure fields * #251 : Rotation support * #253 : User defined hook in the render thread prior to each rendering * #254 : Process deadlocks at closing on Windows * #255 : Motion, entered and left signals for drawables * #256 : Rotation of drawables are not handled for picking * #257 : Conversion fuctions between canvas, drawable and image spaces * #258 : PgmImageSink should send GstEvents on the pipeline for mouse mo... * #260 : [win32] the window is shown at creation * #262 : Mouse related signals are emitted even if opacity is 0 * #263 : [win32] no possibility to get the win32 windows handle from a p... * #264 : [win32] Fullscreen crashes with Intel chipsets/drivers API added since 0.3.5: * PgmViewportCapacity::PGM_VIEWPORT_TOUCHPAD enum field * PgmEventType::PGM_BUTTON_PRESSURE enum field * PgmEventMotion::pressure struct field * PgmEventButton::pressure struct field * PgmViewport::button-pressure-event signal * PgmDrawable::pressured signal * pgm_image_set_from_system_buffer() function * pgm_image_system_buffer_lock() function * pgm_image_system_buffer_unlock() function * PgmImageSystemBuffer struct * PgmImageStorageType::PGM_IMAGE_SYSTEM_BUFFER struct field * PgmDrawableProperty::PGM_IMAGE_DATA_SYSTEM_BUFFER struct field * PgmDrawableProperty::PGM_IMAGE_SYSTEM_BUFFER_CONTENT struct field * PgmViewportCapacity::PGM_VIEWPORT_X11_SYSTEM_BUFFER struct field * PgmViewportReflection struct * PgmViewportRotation struct * pgm_viewport_set_canvas_rotation() function * pgm_viewport_get_canvas_rotation() function * pgm_viewport_set_canvas_reflection() function * pgm_viewport_get_canvas_reflection() function * pgm_drawable_set_rotation_x() function * pgm_drawable_get_rotation_x() function * pgm_drawable_set_rotation_y() function * pgm_drawable_get_rotation_y() function * pgm_drawable_set_rotation_z() function * pgm_drawable_get_rotation_z() function * pgm_viewport_emit_update_pass() function * PgmViewport::update-pass signal * pgm_drawable_from_canvas() function * pgm_drawable_to_canvas() function * pgm_image_from_drawable() function * pgm_image_to_drawable() function * PgmImageSinkEventMask struct * PgmImageSink::events property * pgm_image_sink_set_events() function * pgm_image_sink_get_events() function API changed since 0.3.5: * PgmDrawable::pressed signal prototype * PgmDrawable::clicked signal prototype * PgmDrawable::drag-begin signal prototype * PgmDrawable::drag-motion signal prototype * PgmDrawable::released signal prototype * PgmViewport::delete-event signal prototype * Removed PgmEventDelete struct svn path=/maintainer/; revision=98
-rw-r--r--media-libs/pigment/ChangeLog183
-rw-r--r--media-libs/pigment/Manifest4
-rw-r--r--media-libs/pigment/pigment-0.3.7.ebuild39
3 files changed, 225 insertions, 1 deletions
diff --git a/media-libs/pigment/ChangeLog b/media-libs/pigment/ChangeLog
index 99fc30e..17b05c6 100644
--- a/media-libs/pigment/ChangeLog
+++ b/media-libs/pigment/ChangeLog
@@ -2,6 +2,189 @@
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 20 Aug 2008; Daniel Gryniewicz <dang@gentoo.org> ++:
+ Bump to pigment-0.3.7
+
+ * Added support to get Windows messages from the main loop.
+
+ * Fixed unit test failing on 64 bits systems.
+
+ * #267 : Failure in make check's PgmImage suite
+
+ * #270 : Documentation for "released" signal in Drawable posibly wrong
+
+ * pgm_viewport_set_message_filter() function
+
+ * pgm_viewport_get_message_filter() function
+
+ * PgmViewport::win32-message-event signal
+
+ * PgmEventType::PGM_WIN32_MESSAGE enum field
+
+ * PgmEventWin32Message struct
+
+ * Added an OpenGL ES-CM 1.1 plugin.
+
+ * Added support for the GLX texture-from-pixmap extension.
+
+ * Added support to rotate drawables.
+
+ * Highly improved Windows support.
+
+ * Added support to rotate and reflect a canvas.
+
+ * Added support for pressure events coming from touchscreens.
+
+ * Added motion, entered and left signals to drawables.
+
+ * Added support for mouse navigation events in the GStreamer image sink
+
+ to handle DVD menu elements for instance.
+
+ * Added support to transform positions from/to viewport, canvas or image
+
+ coordinate spaces.
+
+ * #8 : Spline interpolation
+
+ * #63 : Hardware video overlay
+
+ * #144 : Segfault while trying to open video
+
+ * #145 : we can't use in pipeline drawable not added to a canvas
+
+ * #178 : Enter/leave drawable signals
+
+ * #208 : implicit animation leaks
+
+ * #210 : examples on gutsy: `PGM_IS_VIEWPORT (viewport)' failed
+
+ * #223 : Drawables "released" signal prototype inconsistency
+
+ * #224 : [repository] The common/ external should be dropped
+
+ * #235 : pigment locks when windows is out of screen
+
+ * #239 : Bad error handling: exit(1) in main loop due to
+ glXChooseFBConf...
+
+ * #244 : support for GLX_EXT_texture_from_pixmap in OpenGL on X11
+
+ * #245 : Rotation and reflection of the canvas
+
+ * #248 : C++ reserved keywords used as structure fields
+
+ * #251 : Rotation support
+
+ * #253 : User defined hook in the render thread prior to each rendering
+
+ * #254 : Process deadlocks at closing on Windows
+
+ * #255 : Motion, entered and left signals for drawables
+
+ * #256 : Rotation of drawables are not handled for picking
+
+ * #257 : Conversion fuctions between canvas, drawable and image spaces
+
+ * #258 : PgmImageSink should send GstEvents on the pipeline for mouse
+ mo...
+
+ * #260 : [win32] the window is shown at creation
+
+ * #262 : Mouse related signals are emitted even if opacity is 0
+
+ * #263 : [win32] no possibility to get the win32 windows handle from a
+ p...
+
+ * #264 : [win32] Fullscreen crashes with Intel chipsets/drivers API added
+ since 0.3.5:
+
+ * PgmViewportCapacity::PGM_VIEWPORT_TOUCHPAD enum field
+
+ * PgmEventType::PGM_BUTTON_PRESSURE enum field
+
+ * PgmEventMotion::pressure struct field
+
+ * PgmEventButton::pressure struct field
+
+ * PgmViewport::button-pressure-event signal
+
+ * PgmDrawable::pressured signal
+
+ * pgm_image_set_from_system_buffer() function
+
+ * pgm_image_system_buffer_lock() function
+
+ * pgm_image_system_buffer_unlock() function
+
+ * PgmImageSystemBuffer struct
+
+ * PgmImageStorageType::PGM_IMAGE_SYSTEM_BUFFER struct field
+
+ * PgmDrawableProperty::PGM_IMAGE_DATA_SYSTEM_BUFFER struct field
+
+ * PgmDrawableProperty::PGM_IMAGE_SYSTEM_BUFFER_CONTENT struct field
+
+ * PgmViewportCapacity::PGM_VIEWPORT_X11_SYSTEM_BUFFER struct field
+
+ * PgmViewportReflection struct
+
+ * PgmViewportRotation struct
+
+ * pgm_viewport_set_canvas_rotation() function
+
+ * pgm_viewport_get_canvas_rotation() function
+
+ * pgm_viewport_set_canvas_reflection() function
+
+ * pgm_viewport_get_canvas_reflection() function
+
+ * pgm_drawable_set_rotation_x() function
+
+ * pgm_drawable_get_rotation_x() function
+
+ * pgm_drawable_set_rotation_y() function
+
+ * pgm_drawable_get_rotation_y() function
+
+ * pgm_drawable_set_rotation_z() function
+
+ * pgm_drawable_get_rotation_z() function
+
+ * pgm_viewport_emit_update_pass() function
+
+ * PgmViewport::update-pass signal
+
+ * pgm_drawable_from_canvas() function
+
+ * pgm_drawable_to_canvas() function
+
+ * pgm_image_from_drawable() function
+
+ * pgm_image_to_drawable() function
+
+ * PgmImageSinkEventMask struct
+
+ * PgmImageSink::events property
+
+ * pgm_image_sink_set_events() function
+
+ * pgm_image_sink_get_events() function API changed since 0.3.5:
+
+ * PgmDrawable::pressed signal prototype
+
+ * PgmDrawable::clicked signal prototype
+
+ * PgmDrawable::drag-begin signal prototype
+
+ * PgmDrawable::drag-motion signal prototype
+
+ * PgmDrawable::released signal prototype
+
+ * PgmViewport::delete-event signal prototype
+
+ * Removed PgmEventDelete struct
+
05 Mar 2008; Daniel Gryniewicz <dang@gentoo.org> ++, ++:
Bump to 0.3.5
diff --git a/media-libs/pigment/Manifest b/media-libs/pigment/Manifest
index 0da4a40..edc1c16 100644
--- a/media-libs/pigment/Manifest
+++ b/media-libs/pigment/Manifest
@@ -1,5 +1,7 @@
DIST pigment-0.3.3.tar.gz 988556 RMD160 b5bae22c86200dbef704295befa98cbcfc6c6ffb SHA1 90f4c97602b9a62d652e94ef7085bc991f97e53b SHA256 e58cfa66ae774efb889662a0cf6530934796504cd7ef397fd74d051e9cb7126f
DIST pigment-0.3.5.tar.gz 1030295 RMD160 7971996fa93f697bc43a376517429d3d7e1621e7 SHA1 2e8d3c1c3b93d679e3e61d55463db3b563eb43e2 SHA256 7380616e1ff76568fbf9565aef95b1e39e3b4dd922304a6f105c1607b23b0678
+DIST pigment-0.3.7.tar.gz 1135563 RMD160 d15eb6419133d4f6a17e19052d3a71eef052eb5a SHA1 8e54f92d603a7c7232cb5ecfb28cc84aa89bf2e0 SHA256 894aaab0ce9c6fd586ebd8f438180eeaed00672445ca82aae237f5bd1bd42523
EBUILD pigment-0.3.3.ebuild 796 RMD160 21d059b93ee74150e30e40f2792f9dfd4239af82 SHA1 d20616d47e487e148dced17187bd00741339a6f9 SHA256 b8d93c0151cd0e8f9752129c1fc1104ad59855a8192204282845eb4e01dbea56
EBUILD pigment-0.3.5.ebuild 846 RMD160 422bbe45c19d8ff08dfa669e5b747260c0e03cd7 SHA1 a46f594e0a75601c986f78a24cbab6a0b205062d SHA256 e6af33fb80db12a5038f753cefe10f5bd44769ab39f0f9ac02fe32f76a34bc53
-MISC ChangeLog 6468 RMD160 7898faaebeaad8787f48fdd29217095f9de5335d SHA1 c686a596a47b247df39a42cfb702124594124193 SHA256 3ecfa367f314d684e33a0975ebfae61fcf90678f05708d65d59607242b0cb328
+EBUILD pigment-0.3.7.ebuild 910 RMD160 f25f71bcabb4baec178a67c49eee36b2f74ffb72 SHA1 4ed610ab24bfef925a2ddbba651f3d6d42c0c491 SHA256 77f1d05251735958d0caed9d48b76282a312e71063d9bafc61b4fa398382029b
+MISC ChangeLog 11049 RMD160 16099f33f2831c6e8d264457201d08485d21bed4 SHA1 e2817d2f25741dbb6a7367b320b16c1715adcbf7 SHA256 47c969a9b338aacd167a73144cba833985b38e9c996502fcabea96dd75d7a7ae
diff --git a/media-libs/pigment/pigment-0.3.7.ebuild b/media-libs/pigment/pigment-0.3.7.ebuild
new file mode 100644
index 0000000..69eec7e
--- /dev/null
+++ b/media-libs/pigment/pigment-0.3.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2006-2007 BreakMyGentoo.org
+# Distributed under the terms of the GNU General Public License v2
+
+inherit gnome2 multilib
+
+DESCRIPTION="Rendering, animation and widget framework for Elisa media center."
+HOMEPAGE="http://elisa.fluendo.com/"
+SRC_URI="http://elisa.fluendo.com/static/download/${PN}/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=media-libs/gstreamer-0.10.13
+ >=media-libs/gst-plugins-base-0.10.13
+ >=x11-libs/gtk+-2.12
+ >=x11-libs/pango-1.16
+ >=x11-libs/cairo-1.4
+ x11-libs/libXcomposite
+ x11-libs/libX11
+ dev-libs/check
+ >=dev-python/gst-python-0.10
+ doc? ( dev-util/gtk-doc )"
+
+DEPEND="${DEPEND}"
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README TODO"
+
+G2CONF="${G2CONF} $(use_enable doc gtk-doc)"
+
+#MAKEOPTS="-j1"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}