summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-07-09 13:03:41 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-07-09 13:03:41 +0000
commit1fb67961b5812cd33c79e32b4510011df38fa34c (patch)
tree54b97cf458de3a1bbf30868856211f785f438060
parentbump to vala-0.3.4 (diff)
downloadmaintainer-1fb67961b5812cd33c79e32b4510011df38fa34c.tar.gz
maintainer-1fb67961b5812cd33c79e32b4510011df38fa34c.tar.bz2
maintainer-1fb67961b5812cd33c79e32b4510011df38fa34c.zip
Add gupnp-media-server
svn path=/maintainer/; revision=93
-rw-r--r--dev-vala/gupnp-vala/Manifest2
-rw-r--r--dev-vala/gupnp-vala/gupnp-vala-0.2.ebuild28
-rw-r--r--net-libs/gssdp/Manifest2
-rw-r--r--net-libs/gssdp/gssdp-0.6.1.ebuild32
-rw-r--r--net-libs/gupnp-av/Manifest2
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.2.1.ebuild27
-rw-r--r--net-libs/gupnp/Manifest2
-rw-r--r--net-libs/gupnp/gupnp-0.12.ebuild33
-rw-r--r--net-misc/gupnp-media-server/Manifest2
-rw-r--r--net-misc/gupnp-media-server/gupnp-media-server-0.1.ebuild28
-rw-r--r--profiles/categories1
-rw-r--r--skel.ChangeLog67
12 files changed, 226 insertions, 0 deletions
diff --git a/dev-vala/gupnp-vala/Manifest b/dev-vala/gupnp-vala/Manifest
new file mode 100644
index 0000000..03b2e71
--- /dev/null
+++ b/dev-vala/gupnp-vala/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-vala-0.2.tar.gz 104611 RMD160 f2770e368ef7da5915544c7a02e3b32fbbfbcaa9 SHA1 d23dce8dbd340f501d9d5c4f9b27ef74c37069c1 SHA256 0afb40ee8663188d1cf2c4dd05f70eae70bf6d9fd9768a3c550676bcc14fed22
+EBUILD gupnp-vala-0.2.ebuild 561 RMD160 f63cecba90a32761f4b7601711c2b60f664f6de0 SHA1 f7c96517d988892b366f7cbe52ea92e65b79427c SHA256 d4bd121b741937752a90bdf1d4dac9372f501936385b98fbe9672a4d9245b0df
diff --git a/dev-vala/gupnp-vala/gupnp-vala-0.2.ebuild b/dev-vala/gupnp-vala/gupnp-vala-0.2.ebuild
new file mode 100644
index 0000000..6ccf4a3
--- /dev/null
+++ b/dev-vala/gupnp-vala/gupnp-vala-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Vala bindings for gupnp"
+HOMEPAGE="http://gupnp.org/"
+SRC_URI="http://gupnp.org/sources/bindings/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/vala-0.3.4
+ >=net-libs/gssdp-0.6.1
+ >=net-libs/gupnp-0.12
+ >=net-libs/gupnp-ui-0.1
+ >=net-libs/gupnp-av-0.2.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
diff --git a/net-libs/gssdp/Manifest b/net-libs/gssdp/Manifest
new file mode 100644
index 0000000..15c496b
--- /dev/null
+++ b/net-libs/gssdp/Manifest
@@ -0,0 +1,2 @@
+DIST gssdp-0.6.1.tar.gz 402847 RMD160 3ee368e4d1589dccc59bf9a1f9e6357503361167 SHA1 1705d73a051a96ef92bcabe6c72836e2abd63c99 SHA256 ee402ca2c739a13e689a844b27c2199ec6d0821380c65389cd4b6d72811e8ad6
+EBUILD gssdp-0.6.1.ebuild 852 RMD160 23029108c894c7417eded1f7b9dff76230abe647 SHA1 81fd15a5d9243968f5987fa655ea7e5776434e10 SHA256 6c23792443ff865dc6a04e8692813f09ddf9ff6ce292ad9891633ae58567afdd
diff --git a/net-libs/gssdp/gssdp-0.6.1.ebuild b/net-libs/gssdp/gssdp-0.6.1.ebuild
new file mode 100644
index 0000000..bda7b37
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/gssdp-0.4.2.ebuild,v 1.1 2008/04/24 15:17:49 drac Exp $
+
+EAPI=1
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://gupnp.org/sources/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND=">=dev-libs/glib-2.9.1
+ net-libs/libsoup:2.2
+ X? ( >=gnome-base/libglade-2.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --disable-gtk-doc $(use_with X libglade)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/net-libs/gupnp-av/Manifest b/net-libs/gupnp-av/Manifest
new file mode 100644
index 0000000..9258630
--- /dev/null
+++ b/net-libs/gupnp-av/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-av-0.2.1.tar.gz 392016 RMD160 1e41cf37486bec2eb43308e63beaeb1b9c8a750d SHA1 3fddeb7d74b267c5882d05e717390b35ae807ce7 SHA256 46c06e6a0f382adf8e00a77ee71051d7437bd194fb151d1e2c313a71d067a5a1
+EBUILD gupnp-av-0.2.1.ebuild 757 RMD160 f20e822d78f9c60921a7fa829fb4d42f238e10b9 SHA1 aab1a450b690935a7d70ed930994439f9d66a554 SHA256 157439afe70aa2d321d5e6b027afbc21a91de1bcd3fbedc3c32b41ffe454e5df
diff --git a/net-libs/gupnp-av/gupnp-av-0.2.1.ebuild b/net-libs/gupnp-av/gupnp-av-0.2.1.ebuild
new file mode 100644
index 0000000..b78cb30
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/gupnp-av-0.1.ebuild,v 1.1 2008/04/24 15:29:11 drac Exp $
+
+DESCRIPTION="a small utility library that aims to ease the handling UPnP A/V profiles."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://gupnp.org/sources/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=net-libs/gupnp-0.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking --disable-gtk-doc
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
new file mode 100644
index 0000000..4e4dcfd
--- /dev/null
+++ b/net-libs/gupnp/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-0.12.tar.gz 542716 RMD160 9af59f9f6417d264305362241fba926c2651712c SHA1 16963e2bc2eb36f356e1b5e227b0d52e8f7d6517 SHA256 cf2b40be61556b097577e35414e56cb67ad12718f0501fe4585694d337cea1ea
+EBUILD gupnp-0.12.ebuild 842 RMD160 e9ccd23ccbb6511c435544f83dca83a77305dc2a SHA1 dc5d37914fa8b05bd64d50dceafadbc3da4357b5 SHA256 faccb3d3994c7f860ba71b799e61695a5cb1e9461af355fbabfd695867432a26
diff --git a/net-libs/gupnp/gupnp-0.12.ebuild b/net-libs/gupnp/gupnp-0.12.ebuild
new file mode 100644
index 0000000..862d5b0
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.8.ebuild,v 1.1 2008/04/24 15:20:00 drac Exp $
+
+EAPI=1
+
+DESCRIPTION="an object-oriented framework for creating UPnP devs and control points."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://${PN}.org/sources/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/gssdp-0.3
+ net-libs/libsoup:2.2
+ dev-libs/libxml2
+ x11-misc/shared-mime-info
+ sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_compile() {
+ econf --disable-dependency-tracking --disable-gtk-doc
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/net-misc/gupnp-media-server/Manifest b/net-misc/gupnp-media-server/Manifest
new file mode 100644
index 0000000..aa5cd8e
--- /dev/null
+++ b/net-misc/gupnp-media-server/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-media-server-0.1.tar.gz 376265 RMD160 c8c05f6fcbfdd5e41cd2cb24f44d4dda29e4c513 SHA1 51003e1d6613d7811cf8d1cd6ee1948c1b7b06c8 SHA256 c97246d010a6b5ed8ecc731de89ad39c6bfcd3f04d22945fadba456b3bbc8bc9
+EBUILD gupnp-media-server-0.1.ebuild 599 RMD160 91616e6dd66d884f21b4765814535054306ee5bd SHA1 73c40d16e0aa1126e7028dfcfc77c0ffc42ef25f SHA256 9781d281fe1ee22cdf793abb2fcfb6828e1e56dcbcf0912cd932b2ed02919e10
diff --git a/net-misc/gupnp-media-server/gupnp-media-server-0.1.ebuild b/net-misc/gupnp-media-server/gupnp-media-server-0.1.ebuild
new file mode 100644
index 0000000..3a9e508
--- /dev/null
+++ b/net-misc/gupnp-media-server/gupnp-media-server-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A UPNP media server"
+HOMEPAGE="http://gupnp.org/sources/gupnp-media-server/"
+SRC_URI="http://gupnp.org/sources/gupnp-media-server/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/vala-0.3.4
+ >=dev-vala/gupnp-vala-0.2
+ >=net-libs/gupnp-av-0.1
+ >=gnome-base/gconf-2.22
+ >=dev-libs/dbus-glib-0.74"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
diff --git a/profiles/categories b/profiles/categories
new file mode 100644
index 0000000..1f4f53c
--- /dev/null
+++ b/profiles/categories
@@ -0,0 +1 @@
+dev-vala
diff --git a/skel.ChangeLog b/skel.ChangeLog
new file mode 100644
index 0000000..1f22d12
--- /dev/null
+++ b/skel.ChangeLog
@@ -0,0 +1,67 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*<PACKAGE_NAME>-<PACKAGE_VERSION>-<PACKAGE_RELEASE> (DD MMM YYYY)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2 :
+ Initial import. Ebuild submitted by submitter_name <submitter_email>.
+ Note that the "changed_file" listing is optional if you are simply bumping
+ the rev of the ebuild and are only making changes to the .ebuild file
+ itself. Also note that we now have a single unified paragraph rather than
+ having the first line separated from the rest by a newline. Everything
+ should be in one block like this. (note by drobbins, 16 Jul 2002)
+
+ DD MMM YYYY; YOUR_NAME <YOUR_EMAIL> changed_file1, changed_file2: this is
+ an earlier ChangeLog entry.
+
+-- Explanation of ChangeLog format:
+
+ ***************************************************************************
+ THIS IS IMPORTANT: The ChangeLog format is a *chronological* account of all
+ changes made to a set of ebuilds. That means that the most recent ChangeLog
+ entry *always* goes at the top of the file. More explanation below.
+ ***************************************************************************
+
+ ***************************************************************************
+ ANOTHER IMPORTANT NOTE: There are some ChangeLogs that don't follow this
+ format and organize all changes under the "correct" "*" entry. This is not
+ correct. However, rather than making a concerted effort to fix these
+ ChangeLogs, we should spend our energy defining a comprehensive and strict
+ XML-based ChangeLog format which we then migrate to. But for any entries to
+ any ChangeLog that *you* make, please make sure to always add entries to the
+ top of the file like a good boy/girl. Even do this if it's clear that you're
+ adding an entry to a b0rked ChangeLog.
+ ***************************************************************************
+
+ This changelog is targeted to users. This means that the comments should be
+ well explained and written in clean English.
+
+ Every new version or revision of the package should be marked by a '*'
+ separator line as above to indicate where in the chronology it was first
+ added to our CVS tree. Any changes since the last revision, really _any
+ changes at all_ have to be added to the top of the file, underneath the
+ initial copyright and cvs header comments, in exactly the same format as this
+ comment. If you are modifying older ebuilds, simply note them as changed
+ files and add your entry to the top of the ChangeLog. Resist the temptation
+ to "organize" your ChangeLog entries by placing them under the "correct" "*"
+ entries -- this isn't the purpose of the "*" entries.
+
+ This means that you start with header line that has the following format,
+ indented two spaces:
+
+ DD MMM YYYY; your_name <your_email> changed_file1, changed_file2: Your
+ explanation should follow. It should be indented and wrapped at a line width
+ of 80 characters. The changed_files can be omitted if they are obvious; for
+ example, if you are only modifying the .ebuild file and committing a new rev
+ of a package. Any details about what exactly changed in the code should be
+ added as a message when the changes are committed to cvs, not in this file.
+
+-- A word regarding credit:
+
+ Please add credit information ("ebuild submitted by ...", "patch submitted
+ by ...") to the ChangeLog. Do not add this information to the ebuilds
+ themselves.
+
+ And remember: Give credit where credit is due. We're all doing this for
+ free, so the best we can hope (and expect!) to receive is credit.