summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2011-06-20 16:15:00 +0100
committerRobert Piasek <dagger@gentoo.org>2011-06-20 16:15:00 +0100
commit0ce32dadd223aaf7ddc6a2a60d57d0f495e3b235 (patch)
tree903a4e40802c6652afc1dbb4938d0b1a9c368b50 /www-apps/zarafa-webaccess/zarafa-webaccess-6.40.9.ebuild
parentAdd version 6.40.8. (diff)
downloaddagger-0ce32dadd223aaf7ddc6a2a60d57d0f495e3b235.tar.gz
dagger-0ce32dadd223aaf7ddc6a2a60d57d0f495e3b235.tar.bz2
dagger-0ce32dadd223aaf7ddc6a2a60d57d0f495e3b235.zip
Add version 6.40.9
Diffstat (limited to 'www-apps/zarafa-webaccess/zarafa-webaccess-6.40.9.ebuild')
-rw-r--r--www-apps/zarafa-webaccess/zarafa-webaccess-6.40.9.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/www-apps/zarafa-webaccess/zarafa-webaccess-6.40.9.ebuild b/www-apps/zarafa-webaccess/zarafa-webaccess-6.40.9.ebuild
new file mode 100644
index 0000000..1ca4016
--- /dev/null
+++ b/www-apps/zarafa-webaccess/zarafa-webaccess-6.40.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit versionator webapp eutils depend.php
+
+ZARAFA_MAJOR=$(get_version_component_range 1 ${PV})
+ZARAFA_MINOR=$(get_version_component_range 2 ${PV})
+ZARAFA_MICRO=$(get_version_component_range 3 ${PV})
+ZARAFA_REV=27553
+
+DESCRIPTION="Open Source Groupware Solution"
+HOMEPAGE="http://zarafa.com/"
+SRC_URI="http://download.zarafa.com/community/final/${ZARAFA_MAJOR}.${ZARAFA_MINOR}/${PV}-${ZARAFA_REV}/sourcecode/zcp-${PV}.tar.gz"
+
+LICENSE="AGPL-3"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+need_php_httpd
+
+S="${WORKDIR}"/${P/-webaccess/}/php-webclient-ajax
+
+RDEPEND=">=dev-libs/libical-0.40"
+DEPEND="${RDEPEND}"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use iconv session xml
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # make .po files
+ for pofile in "${S}"/server/language/*/LC_MESSAGES/zarafa.po; do
+ msgfmt -f -o ${pofile%%.po}.mo ${pofile}
+ rm ${pofile}
+ done
+
+ dodir /var/lib/zarafa-webaccess/plugins
+ dodir /var/lib/zarafa-webaccess/tmp
+ dosym /var/lib/zarafa-webaccess/plugins "${MY_HTDOCSDIR}"/plugins
+
+ # remove unneeded files
+ rm zarafa-webaccess.conf
+
+ cp "${S}"/config.php.dist "${S}"/config.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r "${S}"/*
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php
+
+ webapp_src_install
+}