summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild')
-rw-r--r--apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild b/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild
new file mode 100644
index 0000000..b1df651
--- /dev/null
+++ b/apps/dev-libs/dnmalloc/dnmalloc-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit multilib
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Safer memory allocator."
+HOMEPAGE="http://fort-knox.org/"
+SRC_URI="http://fort-knox.org/files/${P}.tar.gz"
+LICENSE="LGPL"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ sed -e "s|/usr/local/lib|$(get_libdir)|g" -i Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install || die "emake install failed"
+}