summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCHTEKK <CHTEKK@localhost>2008-11-02 23:03:20 +0000
committerCHTEKK <CHTEKK@localhost>2008-11-02 23:03:20 +0000
commit59262ee4e2886f54b49b74045f2fdfca08f6a3d1 (patch)
tree8f9b376aab00bbd5d2be2b3467296971e37f1a89
parentAdd manifests. (diff)
downloadchtekk-59262ee4e2886f54b49b74045f2fdfca08f6a3d1.tar.gz
chtekk-59262ee4e2886f54b49b74045f2fdfca08f6a3d1.tar.bz2
chtekk-59262ee4e2886f54b49b74045f2fdfca08f6a3d1.zip
Add brother-brscan2 SANE scanner driver.
svn path=/; revision=101
-rw-r--r--apps/media-gfx/brother-brscan2/Manifest3
-rw-r--r--apps/media-gfx/brother-brscan2/brother-brscan2-0.2.4.ebuild33
2 files changed, 36 insertions, 0 deletions
diff --git a/apps/media-gfx/brother-brscan2/Manifest b/apps/media-gfx/brother-brscan2/Manifest
new file mode 100644
index 0000000..eaa810b
--- /dev/null
+++ b/apps/media-gfx/brother-brscan2/Manifest
@@ -0,0 +1,3 @@
+DIST brscan2-0.2.4-0.i386.rpm 74179 RMD160 ed447ebfa12bd0448d1692ae1a601215db045969 SHA1 86ae5326049e610aaab30d06f9c066fefae1cbcb SHA256 5e72834f04622a9f7673c0ed76d2847fff1d31db57415e3629ad13e34701f075
+DIST brscan2-0.2.4-0.x86_64.rpm 85559 RMD160 2d4d9be69c66c8b808f61d56637cbccdc9b6357c SHA1 77d55a81d33e821805b1d2adfecdc28853c99a33 SHA256 bfee8988cd71fb73fe3bb1925689e9a1ff8abaeb97d24c6a662cffc121d7740f
+EBUILD brother-brscan2-0.2.4.ebuild 786 RMD160 b66f3dcf8ac53df3360e06efffe0b9739b9deb66 SHA1 5afad81be05851914813ecc7ab4a4fe62e58a950 SHA256 91a33009434d352daa1f8602e464a316f9e7f6c8c417e61a30337390fd41e66c
diff --git a/apps/media-gfx/brother-brscan2/brother-brscan2-0.2.4.ebuild b/apps/media-gfx/brother-brscan2/brother-brscan2-0.2.4.ebuild
new file mode 100644
index 0000000..7edbee6
--- /dev/null
+++ b/apps/media-gfx/brother-brscan2/brother-brscan2-0.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit rpm
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="Brother brscan2 scanner driver."
+HOMEPAGE="http://solutions.brother.com/linux/en_us/index.html"
+SRC_URI="amd64? ( http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/sane_others/64bit/brscan2-${PV}-0.x86_64.rpm )
+ x86? ( http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/sane_others/brscan2-${PV}-0.i386.rpm )"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=media-gfx/sane-backends-1.0.19"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_compile() {
+ echo "Nothing to compile."
+}
+
+src_install() {
+ cp -Rf "./" "${D}/"
+}
+
+pkg_postinst() {
+ ${ROOT}usr/local/Brother/sane/setupSaneScan2 -i
+}