summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-02-01 12:34:11 -0500
committerDane Smith <c1pher@gentoo.org>2012-02-01 12:34:11 -0500
commitde2cac7efa481b66059a457a141b4c5f117b430f (patch)
tree6580a9060fc61e3350ab472246a7c83debf8d901
parentLoop-aes testing. (diff)
downloadc1pher-de2cac7efa481b66059a457a141b4c5f117b430f.tar.gz
c1pher-de2cac7efa481b66059a457a141b4c5f117b430f.tar.bz2
c1pher-de2cac7efa481b66059a457a141b4c5f117b430f.zip
Initial ebuild for pluf.
-rw-r--r--dev-php/pluf/Manifest2
-rw-r--r--dev-php/pluf/metadata.xml10
-rw-r--r--dev-php/pluf/pluf-01022012.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/pluf/Manifest b/dev-php/pluf/Manifest
new file mode 100644
index 0000000..6ecaf06
--- /dev/null
+++ b/dev-php/pluf/Manifest
@@ -0,0 +1,2 @@
+DIST pluf-01022012.zip 610168 RMD160 b96809faa99fc7cec98c1192f039fb4933a9dc1f SHA1 8fcfb3a936f61b2b5595eb9e3de3b232665c93c9 SHA256 e63644897a36c2f770180d4c819961a7df94fdc65ace42d361883f7a717a0224
+EBUILD pluf-01022012.ebuild 513 RMD160 875c9f6ca1bada64d826ef3e17401796b395b0d1 SHA1 382351cef94d4488f7c9105448700c3a0738e03c SHA256 dd7ee029004f60e96689d9821302ade06b619f4da36c122677f0932c79780e56
diff --git a/dev-php/pluf/metadata.xml b/dev-php/pluf/metadata.xml
new file mode 100644
index 0000000..2ba872d
--- /dev/null
+++ b/dev-php/pluf/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>c1pher@gentoo.org</email>
+ <name>Dane Smith</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-php/pluf/pluf-01022012.ebuild b/dev-php/pluf/pluf-01022012.ebuild
new file mode 100644
index 0000000..068d715
--- /dev/null
+++ b/dev-php/pluf/pluf-01022012.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="A PHP WebApp Framework"
+HOMEPAGE="http://pluf.org/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/php
+ dev-php/PEAR-Console_Getopt
+ dev-php/PEAR-Mail
+ dev-php/PEAR-Mail_Mime
+ ${DEPEND}"
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ doins -r src/*
+}