summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2022-07-31 12:43:51 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2022-07-31 12:45:00 +0300
commit3daf2207ef64a48e76050b807656837c842112f6 (patch)
tree2431a894835f5f7c67d6a51c8969e4742c3abb05
parentwin32codecs: drop old (diff)
downloadbircoph-3daf2207ef64a48e76050b807656837c842112f6.tar.gz
bircoph-3daf2207ef64a48e76050b807656837c842112f6.tar.bz2
bircoph-3daf2207ef64a48e76050b807656837c842112f6.zip
media-libs/win32codecs: version bump to 20110131
Update to EAPI 8. Bug: https://bugs.gentoo.org/858896 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--media-libs/win32codecs/Manifest1
-rw-r--r--media-libs/win32codecs/win32codecs-20110131.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/win32codecs/Manifest b/media-libs/win32codecs/Manifest
index e69de29..e8302ea 100644
--- a/media-libs/win32codecs/Manifest
+++ b/media-libs/win32codecs/Manifest
@@ -0,0 +1 @@
+DIST all-20110131.tar.bz2 25863214 SHA256 448e94f6246564f2d815d68ba530ac3adc051f3a33beda63e38075009e5e2c55 SHA512 f9edc8fe227e264da007df0ecf33628bd674e0827d5a61a8d6c47b03317f9c3ac57e1cbc8056a4f3dc2b530420a461535273ead17006df3097f4fd88a6a1ff8b WHIRLPOOL 668132d97297b77911114727285e2b24a6dc55137d41be6b8509286f9cd5ba785398439d798eda5c41eb8d806ba822786c7bf954dcd1abcb7a9c1acef7b3adc8
diff --git a/media-libs/win32codecs/win32codecs-20110131.ebuild b/media-libs/win32codecs/win32codecs-20110131.ebuild
new file mode 100644
index 0000000..4d67427
--- /dev/null
+++ b/media-libs/win32codecs/win32codecs-20110131.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Windows 32-bit binary codecs for video and audio playback support"
+SRC_URI="mirror://mplayer/releases/codecs/all-${PV}.tar.bz2"
+HOMEPAGE="http://www.mplayerhq.hu/"
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="real"
+
+S="${WORKDIR}/all-${PV}"
+
+RESTRICT="strip binchecks"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Daniel Gryniewicz <dang@gentoo.org>
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/win32
+ doins *.dll *.ax *.xa *.acm *.vwp *.drv *.DLL *.qtx *.qts *.DRV *.vcm
+
+ if use real
+ then
+ insinto /usr/$(get_libdir)/real
+ doins *so.6.0
+
+ # copy newly introduced codecs from realplayer10
+ # see the ChangeLog online
+ doins *.so
+
+ # fix bug #80321
+ local x
+ for x in *so.6.0 *.so; do
+ dosym ../real/$x /usr/$(get_libdir)/win32
+ done
+ fi
+
+ dodoc README
+
+ cat > "${T}/50${PN}" <<EOF
+SEARCH_DIRS_MASK="${EPREFIX}/usr/$(get_libdir)/real ${EPREFIX}/usr/$(get_libdir)/win32"
+EOF
+ insinto /etc/revdep-rebuild
+ doins "${T}/50${PN}"
+}