summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-12-03 22:48:20 +0000
committerThilo Bangert <bangert@gentoo.org>2008-12-03 22:48:20 +0000
commit432d70dba7e517a2f5367c9cfb5ed5f68ebe1cf1 (patch)
tree8426e18eb00017d7273e77ab2bfa54ad330624e4 /net-analyzer
parentunmount the correct dev - fix by patrick grimm - thanks (diff)
downloadbangert-432d70dba7e517a2f5367c9cfb5ed5f68ebe1cf1.tar.gz
bangert-432d70dba7e517a2f5367c9cfb5ed5f68ebe1cf1.tar.bz2
bangert-432d70dba7e517a2f5367c9cfb5ed5f68ebe1cf1.zip
sysorb-agent ebuild - x86 only for now
svn path=/ebuilds/; revision=75
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sysorb-agent/ChangeLog8
-rw-r--r--net-analyzer/sysorb-agent/Manifest6
-rw-r--r--net-analyzer/sysorb-agent/files/soagent.confd13
-rwxr-xr-xnet-analyzer/sysorb-agent/files/soagent.initd34
-rw-r--r--net-analyzer/sysorb-agent/metadata.xml13
-rw-r--r--net-analyzer/sysorb-agent/sysorb-agent-4.3.1.ebuild62
6 files changed, 136 insertions, 0 deletions
diff --git a/net-analyzer/sysorb-agent/ChangeLog b/net-analyzer/sysorb-agent/ChangeLog
new file mode 100644
index 0000000..8355d5d
--- /dev/null
+++ b/net-analyzer/sysorb-agent/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/sysorb-agent
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 03 Dec 2008; Thilo Bangert <bangert@gentoo.org> +files/soagent.confd,
+ +files/soagent.initd, +sysorb-agent-4.3.1.ebuild:
+ initial import - x86 only so far
+
diff --git a/net-analyzer/sysorb-agent/Manifest b/net-analyzer/sysorb-agent/Manifest
new file mode 100644
index 0000000..9786043
--- /dev/null
+++ b/net-analyzer/sysorb-agent/Manifest
@@ -0,0 +1,6 @@
+AUX soagent.confd 290 RMD160 b39070b2af7cb8350261ed85470e969da5e5e0e3 SHA1 6cf94723c49de403a5ae9c63930bf80ed7a637ab SHA256 5cd7373873c4bb825e6f134f68d5cd599fba3fecb0a223d814f740e1a7023b9e
+AUX soagent.initd 722 RMD160 ea41494a4683313dceddec0a6e13f9aeaa52d538 SHA1 44ff742904ff72ed10cc533aacfe2545a1d59610 SHA256 3c06374cc2eefcb17dd83f2eb29198289753b568b170ca4b3669e1c956bd8004
+DIST sysorb-agent-3.4.1-4333.debian22.ia32.deb 230454 RMD160 9070679e892f2f0390fa86cd2385238a7cb041d7 SHA1 7f80f3a3a42e0b83e5e2c31d77abc9a138117000 SHA256 d9e2ba905b11c8d181f9e5077cc0ce0bc00a07d402b2fd573a984685fb24a7fb
+EBUILD sysorb-agent-4.3.1.ebuild 1315 RMD160 5d135968c4f616e0342b39e152f74c3bfa5b098d SHA1 b24074947ec374c8f85bb60ea6fed447d75d586e SHA256 29473cd392241a7da4c1d650ff4031362402e7eb67f0c5bcb2009ad5d476c486
+MISC ChangeLog 286 RMD160 ede1ed44c0e87446aa7e8630bfc189732492bc75 SHA1 7470411877d1e657f648a5c2495f6290c7292436 SHA256 f9ea0e0855db1ef92b2c74ce65802e196310a098cafd4cdb6f5511bb11b43f16
+MISC metadata.xml 390 RMD160 e47d664d1fbe5a77d0df111a16ad1dce7db8420f SHA1 a72a2163f46621dcc7e787a3c9c1c0ced666696f SHA256 506915eac7c5b13fdc9f60960633614f5b6d45b49dfcffee6db0b78bbe908c48
diff --git a/net-analyzer/sysorb-agent/files/soagent.confd b/net-analyzer/sysorb-agent/files/soagent.confd
new file mode 100644
index 0000000..ec8025e
--- /dev/null
+++ b/net-analyzer/sysorb-agent/files/soagent.confd
@@ -0,0 +1,13 @@
+NAME=soagent
+SOAGENT=/usr/sbin/$NAME
+PIDFILE=/var/sysorb/$NAME.pid
+TESTCONF=/usr/sbin/sysorb-testconf
+CONF=/etc/sysorb/agent.conf
+
+#
+# You can change this setting if you do now want the sysorb
+# client to run as root. This will cause various checks to
+# not function (!)
+#
+ALLOW_ROOT=YES
+
diff --git a/net-analyzer/sysorb-agent/files/soagent.initd b/net-analyzer/sysorb-agent/files/soagent.initd
new file mode 100755
index 0000000..d11e820
--- /dev/null
+++ b/net-analyzer/sysorb-agent/files/soagent.initd
@@ -0,0 +1,34 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need net
+}
+
+start() {
+ if test "${ALLOW_ROOT}" = YES; then
+ CHUID=""
+ else
+ CHUID="--chuid sysorb"
+ fi
+
+ ebegin "Starting SysOrb Agent"
+ start-stop-daemon --start --name ${NAME} --pidfile ${PIDFILE} ${CHUID} \
+ --startas /bin/sh -- -c "rm -f ${PIDFILE}; ${SOAGENT} --pidfile ${PIDFILE}"
+ eend $? "Failed to start SysOrb Agent"
+}
+
+stop() {
+ ebegin "Stopping SysOrb Agent"
+ start-stop-daemon --stop --name ${NAME} --pidfile ${PIDFILE}
+ eend $? "Failed to stop SysOrb Agent"
+}
+
+checkconfig() {
+ ebegin "Checking SysOrb Agent config"
+ ${TESTCONF} ${CONF} test
+ eend $?
+}
+
diff --git a/net-analyzer/sysorb-agent/metadata.xml b/net-analyzer/sysorb-agent/metadata.xml
new file mode 100644
index 0000000..360e62b
--- /dev/null
+++ b/net-analyzer/sysorb-agent/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+A agent for SysOrb Monitoring System used to checkin to the server.
+The server will then monitor devices on the agent.
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-analyzer/sysorb-agent/sysorb-agent-4.3.1.ebuild b/net-analyzer/sysorb-agent/sysorb-agent-4.3.1.ebuild
new file mode 100644
index 0000000..529caf6
--- /dev/null
+++ b/net-analyzer/sysorb-agent/sysorb-agent-4.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A agent for SysOrb Monitoring System used to checkin to the server."
+HOMEPAGE="http://www.evalesco.com/"
+SRC_URI="ftp://ftp.sysorb.com/3.4.1-4333/sysorb-agent-3.4.1-4333.debian22.ia32.deb"
+
+RESTRICT="fetch"
+
+LICENSE="SysorbAgent"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ ar x "${DISTDIR}/${A}" || die "Source ${A} not found!"
+ mkdir "${S}"
+ cd "${S}"
+ tar xf ../data.tar.gz || die "data.tar.gz not found in deb"
+}
+
+src_install() {
+ dosbin usr/sbin/soagent
+ dosbin usr/sbin/sysorb-testconf
+
+ #install init.d script
+ newinitd "${FILESDIR}/soagent.initd" soagent
+ newconfd "${FILESDIR}/soagent.confd" soagent
+
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/soagent
+
+ dodir /var/log/sysorb
+ fowners sysorb /var/log/sysorb
+
+ dodir /etc/sysorb
+ insinto /etc/sysorb
+ doins etc/sysorb/action.conf.sample
+ doins etc/sysorb/agent.conf
+ doins etc/sysorb/custom.conf.sample
+ doins etc/sysorb/log.conf
+
+ fowners sysorb /etc/sysorb \
+ /etc/sysorb/action.conf.sample \
+ /etc/sysorb/agent.conf \
+ /etc/sysorb/custom.conf.sample \
+ /etc/sysorb/log.conf
+
+ #TODO man pages
+}
+
+pkg_setup() {
+ enewgroup sysorb
+ enewuser sysorb -1 -1 -1 sysorb
+}
+