summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild')
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
index ac382c5..66180e9 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
@@ -94,8 +94,11 @@ src_unpack() {
epatch "${FILESDIR}/${P}"--as-needed.patch
# Allow building with gcc-4.1 (bug #147876)
- sed -i 's/^CFLAGS += $(call test-gcc-flag,$(CC),-nopie)$/&\nCFLAGS += $(call test-gcc-flag,$(CC),-fnopie)/' \
- "${S}"/tools/firmware/{hvmloader,vmxassist}/Makefile
+ for FLAG in -fnopie -nopie -fno-stack-protector -fno-stack-protector-all ;
+ do
+ test-flag-CC ${FLAG} && HARDFLAGS="${HARDFLAGS} ${FLAG}"
+ done
+ sed -i "s/^CFLAGS :=$/& ${HARDFLAGS}/" "${S}"/tools/firmware/{hvmloader,vmxassist}/Makefile
# Allow building with python-2.5 (bug #149138)
# Backported from upstream - should be in 3.0.3