summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-11-03 06:32:05 +0000
committerAndrew Ross <aross@gentoo.org>2006-11-03 06:32:05 +0000
commit6e4e71e741f9bd356f205e40b04b39f47d7269aa (patch)
tree7ae54c718b2e4ef5f1e9db44cf26ae7d692183d8
parentFix pygrub regression from 3.0.2-r4, caused by upstream changing their Makefi... (diff)
downloadaross-6e4e71e741f9bd356f205e40b04b39f47d7269aa.tar.gz
aross-6e4e71e741f9bd356f205e40b04b39f47d7269aa.tar.bz2
aross-6e4e71e741f9bd356f205e40b04b39f47d7269aa.zip
In a 64bit environment, disable hvmloader as well as vmxassist.
svn path=/; revision=31
-rw-r--r--app-emulation/xen-tools/Manifest8
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.3.ebuild9
2 files changed, 9 insertions, 8 deletions
diff --git a/app-emulation/xen-tools/Manifest b/app-emulation/xen-tools/Manifest
index 8cb6665..0e11c35 100644
--- a/app-emulation/xen-tools/Manifest
+++ b/app-emulation/xen-tools/Manifest
@@ -64,10 +64,10 @@ EBUILD xen-tools-3.0.2-r4.ebuild 5606 RMD160 4e79b938e0c67f8b74b0c7a59634e0f9540
MD5 0ddef7e6f6bf4b683d51ac27aed477c8 xen-tools-3.0.2-r4.ebuild 5606
RMD160 4e79b938e0c67f8b74b0c7a59634e0f95408a913 xen-tools-3.0.2-r4.ebuild 5606
SHA256 4bbfe1ce372e6c21e87e7177757b847361669e371dfa9c30ba80590d80527e74 xen-tools-3.0.2-r4.ebuild 5606
-EBUILD xen-tools-3.0.3.ebuild 5069 RMD160 c69781777c691cdf8f6b20796e9246234ac16e0d SHA1 62b2d91edf9d2fc19ae7b76e9c4b02235854fa30 SHA256 ec25868e7abecf5819e6680c02ea355a6080bacda57fd2d79502e2528005a412
-MD5 55d79b00a230987fb98c71cad8c2040f xen-tools-3.0.3.ebuild 5069
-RMD160 c69781777c691cdf8f6b20796e9246234ac16e0d xen-tools-3.0.3.ebuild 5069
-SHA256 ec25868e7abecf5819e6680c02ea355a6080bacda57fd2d79502e2528005a412 xen-tools-3.0.3.ebuild 5069
+EBUILD xen-tools-3.0.3.ebuild 5194 RMD160 9552aa8d220179eaa6ff0d50a0d200be13880e4f SHA1 9aa47ef9eb16c60b7679d8295b0306e993534397 SHA256 6b3e333d1d22ac88a730148e0876abd5915c2f59d8a3a9803b9ee87550742a61
+MD5 be0cb2908bf004a8eb3d9b470085d73b xen-tools-3.0.3.ebuild 5194
+RMD160 9552aa8d220179eaa6ff0d50a0d200be13880e4f xen-tools-3.0.3.ebuild 5194
+SHA256 6b3e333d1d22ac88a730148e0876abd5915c2f59d8a3a9803b9ee87550742a61 xen-tools-3.0.3.ebuild 5194
MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-tools-3.0.2-r3 235
RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-tools-3.0.2-r3 235
SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-tools-3.0.2-r3 235
diff --git a/app-emulation/xen-tools/xen-tools-3.0.3.ebuild b/app-emulation/xen-tools/xen-tools-3.0.3.ebuild
index 9c23ff7..9543f9c 100644
--- a/app-emulation/xen-tools/xen-tools-3.0.3.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.0.3.ebuild
@@ -8,7 +8,7 @@ DESCRIPTION="Xend daemon and tools"
HOMEPAGE="http://xen.sourceforge.net"
XEN_VERSION="3.0.3_0"
SRC_URI="http://bits.xensource.com/oss-xen/release/${XEN_VERSION/_/-}/src.tgz/xen-${XEN_VERSION}-src.tgz"
-S="${WORKDIR}/xen-${XEN_VERSION}-src"
+S="${WORKDIR}/xen-${XEN_VERSION}-src/"
LICENSE="GPL-2"
SLOT="0"
@@ -85,10 +85,11 @@ src_unpack() {
"${S}"/tools/firmware/{hvmloader,vmxassist}/Makefile
- # Disable the 32bit-only vmxassist if we are not on x86
- # and we don't support the x86 ABI
+ # Disable the 32bit-only vmxassist if we are not on x86 and we don't
+ # support the x86 ABI. Also disable hvmloader, since it requires vmxassist.
if ! use x86 && ! has x86 $(get_all_abis); then
- sed -i -e "/SUBDIRS += vmxassist/d" "${S}"tools/firmware/Makefile
+ sed -i -e "/SUBDIRS += vmxassist/d" "${S}"/tools/firmware/Makefile
+ sed -i -e "/SUBDIRS += hvmloader/d" "${S}"/tools/firmware/Makefile
fi
if use pygrub; then