summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/elegance-colors/elegance-colors-9999.ebuild')
-rw-r--r--x11-themes/elegance-colors/elegance-colors-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-themes/elegance-colors/elegance-colors-9999.ebuild b/x11-themes/elegance-colors/elegance-colors-9999.ebuild
new file mode 100644
index 0000000..1efa298
--- /dev/null
+++ b/x11-themes/elegance-colors/elegance-colors-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit git-r3 vala
+
+DESCRIPTION="a highly customizable chameleon theme for Gnome Shell"
+HOMEPAGE="https://github.com/satya164/elegance-colors"
+EGIT_REPO_URI="https://github.com/satya164/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ vala_src_prepare
+ sed -i -e "s/CC/VALAC/" Makefile
+}
+
+src_compile() {
+ emake VALAC=${VALAC}
+}