summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-02-17 15:57:44 +0100
committerChristoph Mende <angelos@gentoo.org>2011-02-17 15:57:44 +0100
commitbf8d3a7cc9c361535e628b0e60f73951a857923e (patch)
treed39d4e24cc1c51d5d7767d7301821b6e9d575d47 /media-sound
downloadangelos-bf8d3a7cc9c361535e628b0e60f73951a857923e.tar.gz
angelos-bf8d3a7cc9c361535e628b0e60f73951a857923e.tar.bz2
angelos-bf8d3a7cc9c361535e628b0e60f73951a857923e.zip
Initial import
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/scmpc/Manifest2
-rw-r--r--media-sound/scmpc/files/scmpc.init20
-rw-r--r--media-sound/scmpc/scmpc-9999.ebuild34
3 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/scmpc/Manifest b/media-sound/scmpc/Manifest
new file mode 100644
index 0000000..5166736
--- /dev/null
+++ b/media-sound/scmpc/Manifest
@@ -0,0 +1,2 @@
+AUX scmpc.init 312 RMD160 f307e830f4bb6d3b4ab7b2f63c5c18691de78fc2 SHA1 ce64c856a4b74c1f1a08b5fcd8ba3c701bc8f266 SHA256 478faddcbcb4d2bc6a72565847106c702ae5380a763bf162f459a6b28e0aedd8
+EBUILD scmpc-9999.ebuild 751 RMD160 93599b7eb2ecc52c29f0080deaf67462861d85c6 SHA1 bb0785d1adb095004b224a1505dedee7190a1296 SHA256 6afe53e594dbfe97dc8f823daf1567da674381f4c087d7f3f31669b12e29b8a9
diff --git a/media-sound/scmpc/files/scmpc.init b/media-sound/scmpc/files/scmpc.init
new file mode 100644
index 0000000..978c897
--- /dev/null
+++ b/media-sound/scmpc/files/scmpc.init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ use net mpd
+}
+
+start() {
+ ebegin "Starting scmpc"
+ /usr/bin/scmpc -f /etc/scmpc.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping scmpc"
+ /usr/bin/scmpc -k
+ eend $?
+}
diff --git a/media-sound/scmpc/scmpc-9999.ebuild b/media-sound/scmpc/scmpc-9999.ebuild
new file mode 100644
index 0000000..a89012f
--- /dev/null
+++ b/media-sound/scmpc/scmpc-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+inherit autotools git
+
+DESCRIPTION="a client for MPD which submits your tracks to last.fm"
+HOMEPAGE="http://ngls.zakx.de/scmpc/"
+EGIT_REPO_URI="git://ngls.zakx.de/scmpc.git"
+EGIT_BOOTSTRAP="eautoreconf"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/confuse
+ net-misc/curl"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README scmpc.conf.example
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ insinto /etc
+ insopts -m600
+ newins scmpc.conf.example scmpc.conf
+}
+
+pkg_postinst() {
+ elog "Note: This version of scmpc requires mpd-0.14"
+}