summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-sensors-plugin')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/ChangeLog b/xfce-extra/xfce4-sensors-plugin/ChangeLog
index e5579f0ad355..d914b6a6e9f2 100644
--- a/xfce-extra/xfce4-sensors-plugin/ChangeLog
+++ b/xfce-extra/xfce4-sensors-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-sensors-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.2 2010/02/19 09:11:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.3 2010/03/29 14:53:50 darkside Exp $
+
+*xfce4-sensors-plugin-1.0.0 (29 Mar 2010)
+
+ 29 Mar 2010; Jeremy Olexa <darkside@gentoo.org>
+ +xfce4-sensors-plugin-1.0.0.ebuild:
+ Version bump. http://releases.xfce.org/feeds/project/xfce4-sensors-plugin
19 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
xfce4-sensors-plugin-0.10.99.6.ebuild:
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild
new file mode 100644
index 000000000000..13c9a03aed47
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.0.0.ebuild,v 1.1 2010/03/29 14:53:50 darkside Exp $
+
+EAUTORECONF=yes
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="acpi, lm_sensors and hddtemp panel plugin"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/1.0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="acpi debug hddtemp libnotify lm_sensors"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.4
+ >=xfce-base/libxfcegui4-4.4
+ >=xfce-base/xfce4-panel-4.4
+ libnotify? ( >=x11-libs/libnotify-0.4 )
+ lm_sensors? ( sys-apps/lm_sensors )
+ hddtemp? ( app-admin/hddtemp )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable hddtemp)
+ $(use_enable lm_sensors libsensors)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable debug)
+ $(use_enable libnotify notification)"
+
+ if ! use hddtemp && ! use lm_sensors && ! use acpi; then
+ XFCONF="${XFCONF} --enable-procacpi --enable-sysfsacpi"
+ fi
+
+ DOCS="AUTHORS ChangeLog NEWS NOTES README TODO"
+}
+
+src_prepare() {
+ sed -i -e '/-no-undefined/d' src/Makefile.am || die
+ sed -i -e 's/-Werror//' configure.in || die
+ xfconf_src_prepare
+}