summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/qtcurve/qtcurve-0.58.0.ebuild')
-rw-r--r--x11-themes/qtcurve/qtcurve-0.58.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/qtcurve/qtcurve-0.58.0.ebuild b/x11-themes/qtcurve/qtcurve-0.58.0.ebuild
new file mode 100644
index 000000000000..1819f3a0fd02
--- /dev/null
+++ b/x11-themes/qtcurve/qtcurve-0.58.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/qtcurve-0.58.0.ebuild,v 1.1 2008/03/26 23:38:15 yngwin Exp $
+
+# Order is important, so we get src_compile from cmake-utils.
+inherit kde-functions qt3 cmake-utils
+
+MY_P=${P/qtcurve/QtCurve-KDE3}
+
+DESCRIPTION="A set of widget styles for KDE3 based apps, also available for GTK2 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-util/cmake-2.4
+ $(qt_min_version 3)"
+
+need-kde 3.5
+
+S="${WORKDIR}/${MY_P}"
+DOCS="ChangeLog README TODO"
+
+pkg_postinst() {
+ buildsycoca
+}
+
+pkg_postrm() {
+ buildsycoca
+}