summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmtop/ChangeLog7
-rw-r--r--x11-plugins/wmtop/wmtop-0.9.0.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/x11-plugins/wmtop/ChangeLog b/x11-plugins/wmtop/ChangeLog
index 144e6fb2bf80..cb8ee7199df0 100644
--- a/x11-plugins/wmtop/ChangeLog
+++ b/x11-plugins/wmtop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmtop
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/ChangeLog,v 1.13 2008/11/26 00:05:59 tcunha Exp $
+# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/ChangeLog,v 1.14 2010/09/06 07:59:28 s4t4n Exp $
+
+ 06 Sep 2010; Michele Noberasco <s4t4n@gentoo.org> wmtop-0.9.0.ebuild:
+ Honour Gentoo LDFLAGS. Closes bug #335953.
26 Nov 2008; Tiago Cunha <tcunha@gentoo.org> wmtop-0.9.0.ebuild:
stable sparc, bug 215651
diff --git a/x11-plugins/wmtop/wmtop-0.9.0.ebuild b/x11-plugins/wmtop/wmtop-0.9.0.ebuild
index e6c61fb79cf3..92992e604589 100644
--- a/x11-plugins/wmtop/wmtop-0.9.0.ebuild
+++ b/x11-plugins/wmtop/wmtop-0.9.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/wmtop-0.9.0.ebuild,v 1.4 2008/11/26 00:05:59 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtop/wmtop-0.9.0.ebuild,v 1.5 2010/09/06 07:59:28 s4t4n Exp $
+EAPI=2
inherit multilib toolchain-funcs
DESCRIPTION="dockapp for monitoring the top three processes using cpu or memory."
@@ -20,6 +21,10 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
+src_prepare() {
+ sed -ie "s/\$(FLAGS) -o wmtop/\$(DEBUG) \$(LDFLAGS) -D\$(OS) -o wmtop/" Makefile
+}
+
src_compile() {
emake CC="$(tc-getCC)" OPTS="${CFLAGS}" \
LIBDIR="-L/usr/$(get_libdir)" \