summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmtimer/wmtimer-2.4.ebuild')
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.4.ebuild42
1 files changed, 26 insertions, 16 deletions
diff --git a/x11-plugins/wmtimer/wmtimer-2.4.ebuild b/x11-plugins/wmtimer/wmtimer-2.4.ebuild
index 1973cd70add5..8e8623fecc9b 100644
--- a/x11-plugins/wmtimer/wmtimer-2.4.ebuild
+++ b/x11-plugins/wmtimer/wmtimer-2.4.ebuild
@@ -1,28 +1,38 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.4.ebuild,v 1.1 2002/09/16 16:14:04 raker Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.4.ebuild,v 1.1.1.1 2005/11/30 10:10:37 chriswhite Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}/${PN}
-S=${WORKDIR}/${P}
-S2=${S}/wmtimer
DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
-SRC_URI="http://home.dwave.net/~jking/wmtimer/${P}.tar.gz"
-HOMEPAGE="http://home.dwave.net/~jking/wmtimer/"
+SRC_URI="http://www.darkops.net/wmtimer/${P}.tar.gz"
+HOMEPAGE="http://www.darkops.net/wmtimer/"
SLOT="0"
-LICENSE="GPL"
-KEYWORDS="x86"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64 ppc64 ppc ~sparc"
-DEPEND="virtual/x11"
-RDEPEND="${DEPEND}"
+RDEPEND="=x11-libs/gtk+-1.2*
+ virtual/x11"
+
+DEPEND="virtual/libc
+ ${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O2 -Wall:${CFLAGS}:" Makefile
+}
src_compile() {
- cd ${S2}
emake || die
}
src_install () {
- exeinto /usr/bin
- doexe ${S2}/wmtimer
- cd ${S}
- dodoc README COPYING INSTALL CREDITS INSTALL Changelog
+ dobin wmtimer
+ cd ..
+ dodoc README CREDITS Changelog
}