summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gaim-otr/gaim-otr-2.0.1.ebuild')
-rw-r--r--x11-plugins/gaim-otr/gaim-otr-2.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gaim-otr/gaim-otr-2.0.1.ebuild b/x11-plugins/gaim-otr/gaim-otr-2.0.1.ebuild
new file mode 100644
index 000000000000..58f304f9db34
--- /dev/null
+++ b/x11-plugins/gaim-otr/gaim-otr-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/gaim-otr-2.0.1.ebuild,v 1.1 2005/02/24 18:38:29 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=net-libs/libotr-2.0.1
+ >=net-im/gaim-1.1.0"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc COPYING ChangeLog README
+}