summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/piedock/ChangeLog6
-rw-r--r--x11-misc/piedock/files/piedock-1.6.2-mem.patch22
-rw-r--r--x11-misc/piedock/piedock-1.6.2.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/x11-misc/piedock/ChangeLog b/x11-misc/piedock/ChangeLog
index fdc82a9828b1..30dfc3349639 100644
--- a/x11-misc/piedock/ChangeLog
+++ b/x11-misc/piedock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/piedock
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/piedock/ChangeLog,v 1.21 2013/06/03 11:31:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/piedock/ChangeLog,v 1.22 2013/06/06 15:47:50 jer Exp $
+
+ 06 Jun 2013; Jeroen Roovers <jer@gentoo.org> piedock-1.6.2.ebuild,
+ +files/piedock-1.6.2-mem.patch:
+ Fix building against media-libs/libpng-1.6* (bug #471460).
*piedock-1.6.2 (03 Jun 2013)
diff --git a/x11-misc/piedock/files/piedock-1.6.2-mem.patch b/x11-misc/piedock/files/piedock-1.6.2-mem.patch
new file mode 100644
index 000000000000..30655b94f2fd
--- /dev/null
+++ b/x11-misc/piedock/files/piedock-1.6.2-mem.patch
@@ -0,0 +1,22 @@
+--- a/src/IconMap.cpp
++++ b/src/IconMap.cpp
+@@ -15,7 +15,7 @@
+ #include "WildcardCompare.h"
+ #include "Png.h"
+
+-#include <string>
++#include <string.h>
+ #include <algorithm>
+ #include <sstream>
+ #include <fstream>
+--- a/src/Png.cpp
++++ b/src/Png.cpp
+@@ -13,7 +13,7 @@
+ */
+ #include "Png.h"
+
+-#include <string>
++#include <string.h>
+ #include <fstream>
+ #include <stdexcept>
+
diff --git a/x11-misc/piedock/piedock-1.6.2.ebuild b/x11-misc/piedock/piedock-1.6.2.ebuild
index 16151f700ced..f268bf220f7c 100644
--- a/x11-misc/piedock/piedock-1.6.2.ebuild
+++ b/x11-misc/piedock/piedock-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/piedock/piedock-1.6.2.ebuild,v 1.1 2013/06/03 11:31:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/piedock/piedock-1.6.2.ebuild,v 1.2 2013/06/06 15:47:50 jer Exp $
EAPI=4
inherit eutils
@@ -38,6 +38,7 @@ DOCS=( res/${PN}rc.sample AUTHORS ChangeLog NEWS )
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.6.1-signals.patch
+ epatch "${FILESDIR}"/${PN}-1.6.2-mem.patch
}
src_configure() {