summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/parcellite')
-rw-r--r--x11-misc/parcellite/ChangeLog7
-rw-r--r--x11-misc/parcellite/parcellite-1.1.8.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 307c0f1a66af..adfea35e663e 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.35 2014/04/12 17:13:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.36 2014/07/12 11:06:53 jer Exp $
+
+*parcellite-1.1.8 (12 Jul 2014)
+
+ 12 Jul 2014; Jeroen Roovers <jer@gentoo.org> +parcellite-1.1.8.ebuild:
+ Version bump (bug #516930 by Sasha Medvedev).
12 Apr 2014; Jeroen Roovers <jer@gentoo.org> -parcellite-1.1.4.ebuild,
-parcellite-1.1.5.ebuild, -parcellite-1.1.6.ebuild:
diff --git a/x11-misc/parcellite/parcellite-1.1.8.ebuild b/x11-misc/parcellite/parcellite-1.1.8.ebuild
new file mode 100644
index 000000000000..c2c2ac6e5139
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-1.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.1.8.ebuild,v 1.1 2014/07/12 11:06:53 jer Exp $
+
+EAPI=5
+inherit eutils fdo-mime
+
+MY_P=${PN}-${PV/_}
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.10:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i data/${PN}.desktop.in -e 's:Application;::g' || die
+
+ sed -i -e '/^ALL_LINGUAS=/d' configure || die
+ strip-linguas -i po/
+ export ALL_LINGUAS="${LINGUAS}"
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}