summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obconf/obconf-9999.ebuild')
-rw-r--r--x11-misc/obconf/obconf-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/x11-misc/obconf/obconf-9999.ebuild b/x11-misc/obconf/obconf-9999.ebuild
index d335cce99c31..cc0c6fba9308 100644
--- a/x11-misc/obconf/obconf-9999.ebuild
+++ b/x11-misc/obconf/obconf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/obconf/obconf-9999.ebuild,v 1.7 2011/03/29 13:05:12 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/obconf/obconf-9999.ebuild,v 1.8 2011/08/05 15:53:50 hwoarang Exp $
EAPI="2"
@@ -14,17 +14,21 @@ EGIT_REPO_URI="git://git.openbox.org/dana/obconf.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="nls"
+IUSE="lxde nls"
RDEPEND="gnome-base/libglade:2.0
x11-libs/gtk+:2
x11-libs/startup-notification
- >=x11-wm/openbox-3.4.2"
+ >x11-wm/openbox-3.5.0"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
dev-util/pkgconfig"
src_prepare() {
+ if use lxde; then
+ sed -i -e "/^Exec/s:obconf.*$:obconf-lxde:" ${PN}.desktop || die
+ fi
+ epatch "${FILESDIR}"/${PN}-2.0.3_p20110314-config-path.patch
eautopoint
eautoreconf
}
@@ -35,6 +39,9 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ if use lxde; then
+ dobin "${FILESDIR}"/${PN}-lxde || die
+ fi
dodoc AUTHORS CHANGELOG README || die "dodoc failed"
}