summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtkscintilla2/ChangeLog9
-rw-r--r--x11-libs/gtkscintilla2/Manifest4
-rw-r--r--x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.1.01
-rw-r--r--x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild52
4 files changed, 63 insertions, 3 deletions
diff --git a/x11-libs/gtkscintilla2/ChangeLog b/x11-libs/gtkscintilla2/ChangeLog
index 29a472855c57..9a9548a36f1f 100644
--- a/x11-libs/gtkscintilla2/ChangeLog
+++ b/x11-libs/gtkscintilla2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtkscintilla2
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/ChangeLog,v 1.4 2003/12/13 22:36:45 zul Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/ChangeLog,v 1.5 2004/02/18 10:25:48 liquidx Exp $
+
+*gtkscintilla2-0.1.0 (18 Feb 2004)
+
+ 18 Feb 2004; Alastair Tse <liquidx@gentoo.org> gtkscintilla2-0.1.0.ebuild:
+ version bump
13 Dec 2003; Chuck Short <zul@gentoo.org> gtkscintilla2-0.0.8.ebuild:
Added amd64 support.
diff --git a/x11-libs/gtkscintilla2/Manifest b/x11-libs/gtkscintilla2/Manifest
index 27d94ed5b713..f6033e9ad2e3 100644
--- a/x11-libs/gtkscintilla2/Manifest
+++ b/x11-libs/gtkscintilla2/Manifest
@@ -1,4 +1,6 @@
-MD5 0e83f40e31445d895ecd78c2d8d150c6 gtkscintilla2-0.0.8.ebuild 1137
MD5 34de6c8b5452e261d98f99a945eaf127 ChangeLog 872
+MD5 0e83f40e31445d895ecd78c2d8d150c6 gtkscintilla2-0.0.8.ebuild 1137
+MD5 fe2794211f6b770f898b40ecec9014e3 gtkscintilla2-0.1.0.ebuild 1145
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 f29bb40add3aa939317a482a5351a3fd files/digest-gtkscintilla2-0.0.8 71
+MD5 dc9e42bf3ab4148baffc1e474a266416 files/digest-gtkscintilla2-0.1.0 71
diff --git a/x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.1.0 b/x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.1.0
new file mode 100644
index 000000000000..fb93fc765fb5
--- /dev/null
+++ b/x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.1.0
@@ -0,0 +1 @@
+MD5 7e1a5b6c289155fae49ccb3a1a43f0b2 GtkScintilla2-0.1.0.tar.gz 489304
diff --git a/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild b/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
new file mode 100644
index 000000000000..4c9f560d622d
--- /dev/null
+++ b/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild,v 1.1 2004/02/18 10:25:48 liquidx Exp $
+
+MY_P="GtkScintilla2-${PV}"
+DESCRIPTION="Gtk-2 wrappers for the Scintilla source editing components."
+HOMEPAGE="http://www.gphpedit.org/"
+SRC_URI="http://gphpedit.org/download/files/${MY_P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-libs/gtk+-2.0"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=dev-lang/python-2.2
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ # some quick touches to the Makefile, bump the version
+ # and make use of our CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "/VERSION/s/0.0.3/${PV}/" \
+ -e "/CFLAGS/s/-g/${CFLAGS} -fPIC/" < Makefile.orig > Makefile
+
+ # and again, in the scintilla part
+ cd ${S}/scintilla/gtk
+ cp makefile makefile.orig
+ sed -e "/CXXFLAGS/s/-Os/${CFLAGS} -fPIC/" < makefile.orig > makefile
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ dodoc COPYING README
+
+}