summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/fox/fox-1.0.49.ebuild')
-rw-r--r--x11-libs/fox/fox-1.0.49.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/x11-libs/fox/fox-1.0.49.ebuild b/x11-libs/fox/fox-1.0.49.ebuild
deleted file mode 100644
index a98c356cd139..000000000000
--- a/x11-libs/fox/fox-1.0.49.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.49.ebuild,v 1.13 2005/02/19 08:03:26 corsair Exp $
-
-IUSE="cups opengl"
-DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
-SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
-HOMEPAGE="http://www.fox-toolkit.org"
-SLOT="0"
-KEYWORDS="x86 sparc alpha ia64 hppa amd64 ppc ppc64"
-LICENSE="GPL-2"
-
-DEPEND="virtual/libc
- virtual/x11
- opengl? ( virtual/opengl )"
-
-
-src_compile() {
-
- local myconf
-
- use opengl || myconf="$myconf --with-opengl=no" #default enabled
- use cups && myconf="$myconf --enable-cups" #default disabled
-
- ./configure \
- --prefix=/usr \
- --mandir='${prefix}'/share/man \
- --host=${CHOST} \
- ${myconf} || die "Configuration Failed"
-
- emake || die "Parallel Make Failed"
-}
-
-src_install () {
-
- make prefix=${D}/usr/ \
- install || die "Installation Failed"
-
- dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
-
- dodir /usr/share/doc/${PF}/html
- mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
- rmdir ${D}/usr/fox/html
- rmdir ${D}/usr/fox
-}