summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild')
-rw-r--r--x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild34
1 files changed, 2 insertions, 32 deletions
diff --git a/x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild b/x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild
index 4bbd8bd219cd..ac3cf25dc3f1 100644
--- a/x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild
+++ b/x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild,v 1.8 2002/11/16 03:18:50 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xdirectfb/xdirectfb-1.0_rc2-r1.ebuild,v 1.9 2002/11/18 06:49:54 blizzy Exp $
MY_PN="XDirectFB"
MY_PV=${PV/_/-}
@@ -29,7 +29,6 @@ DEPEND=">=sys-libs/ncurses-5.1
dev-libs/DirectFB"
src_unpack () {
-
unpack ${A}
cd ${X}
@@ -44,16 +43,13 @@ src_unpack () {
# echo "#define DefaultGcc2i386Opt ${CFLAGS}" >> config/cf/host.def
# echo "#define GccWarningOptions -Wno" >> config/cf/host.def
# echo "#define DefaultCCOptions -ansi" >> config/cf/host.def
-
}
src_compile() {
-
emake World || die
}
src_install() {
-
# make install DESTDIR=${D}
exeinto /usr/X11R6/bin
@@ -72,37 +68,11 @@ src_install() {
cd ${X}
dodoc AUTHORS ChangeLog INSTALL README TODO
-
}
pkg_postinst() {
-
chmod 4711 /usr/X11R6/bin/XDirectFB
chmod 755 /usr/X11R6/bin/startxdfb
- echo
- echo '#######################################################'
- echo '# #'
- echo '# To start XDirectFB use startxdfb utility. #'
- echo '# For example startxdfb -- -enableRoot #'
- echo '# Use -enableRoot if you have issues with menus #'
- echo '# not working in fluxbox or blackbox, etc. #'
- echo '# #'
- echo '# To set a background in XDirectFB create a #'
- echo '# file called directfbrc in /etc #'
- echo '# (system wide setting) or .directfbrc #'
- echo '# in $HOME. XDirectFB will also just use your #'
- echo '# Window Managers background. #'
- echo '# #'
- echo '# XDirectFB needs ~/.dfbserverrc or #'
- echo '# /etc/X11/xinit/dfbserverrc by default so please #'
- echo '# edit these to you likeing. #'
- echo '# cp /etc/skel/.dfbserverrc $HOME #'
- echo '# Please take a look at this file and edit it, #'
- echo '# you can add a options like -enableRoot, etc to #'
- echo '# it. Though XDirectFB should just start with #'
- echo '# startxdfb #'
- echo '# #'
- echo '#######################################################'
- echo
+ einfo "To start XDirectFB use the startxdfb utility."
}