summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xwininfo/ChangeLog8
-rw-r--r--x11-apps/xwininfo/files/1.1.0-build.patch16
-rw-r--r--x11-apps/xwininfo/xwininfo-1.1.0.ebuild25
3 files changed, 48 insertions, 1 deletions
diff --git a/x11-apps/xwininfo/ChangeLog b/x11-apps/xwininfo/ChangeLog
index f915574a840b..2b97be8d9620 100644
--- a/x11-apps/xwininfo/ChangeLog
+++ b/x11-apps/xwininfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xwininfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/ChangeLog,v 1.50 2010/01/23 19:28:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/ChangeLog,v 1.51 2010/09/27 12:59:32 scarabeus Exp $
+
+*xwininfo-1.1.0 (27 Sep 2010)
+
+ 27 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.1.0-build.patch, +xwininfo-1.1.0.ebuild:
+ Version bump.
23 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-xwininfo-1.0.3.ebuild, -xwininfo-1.0.4.ebuild:
diff --git a/x11-apps/xwininfo/files/1.1.0-build.patch b/x11-apps/xwininfo/files/1.1.0-build.patch
new file mode 100644
index 000000000000..8eb9c2ac43d1
--- /dev/null
+++ b/x11-apps/xwininfo/files/1.1.0-build.patch
@@ -0,0 +1,16 @@
+diff --git a/xwininfo.c b/xwininfo.c
+index 265f6c6..5660baa 100644
+--- a/xwininfo.c
++++ b/xwininfo.c
+@@ -630,8 +630,9 @@ main (int argc, char **argv)
+ w->wm_pid_cookie = xcb_get_property
+ (dpy, False, window, atom_net_wm_pid,
+ XCB_ATOM_CARDINAL, 0, BUFSIZ);
+- w->wm_client_machine_cookie =
+- GET_TEXT_PROPERTY(dpy, window, XCB_ATOM_WM_CLIENT_MACHINE);
++ w->wm_client_machine_cookie = xcb_get_property
++ (dpy, False, window, XCB_ATOM_WM_CLIENT_MACHINE ,
++ XCB_GET_PROPERTY_TYPE_ANY, 0, BUFSIZ);
+ }
+
+ atom_net_frame_extents = Get_Atom (dpy, "_NET_FRAME_EXTENTS");
diff --git a/x11-apps/xwininfo/xwininfo-1.1.0.ebuild b/x11-apps/xwininfo/xwininfo-1.1.0.ebuild
new file mode 100644
index 000000000000..60c305ed8c45
--- /dev/null
+++ b/x11-apps/xwininfo/xwininfo-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/xwininfo-1.1.0.ebuild,v 1.1 2010/09/27 12:59:32 scarabeus Exp $
+
+EAPI=3
+XORG_STATIC=no
+inherit xorg-2
+
+DESCRIPTION="window information utility for X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libxcb-1.6
+ x11-libs/libX11
+ x11-libs/xcb-util
+ >=x11-proto/xproto-7.0.17"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-build.patch" )
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="--with-xcb-icccm"
+ xorg-2_pkg_setup
+}