summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/orion/ChangeLog9
-rw-r--r--www-servers/orion/orion-2.0.1.ebuild18
-rw-r--r--www-servers/orion/orion-2.0.2.ebuild18
-rw-r--r--www-servers/orion/orion-2.0.5.ebuild20
4 files changed, 35 insertions, 30 deletions
diff --git a/www-servers/orion/ChangeLog b/www-servers/orion/ChangeLog
index d57c47fb9d7b..5e65fe20563f 100644
--- a/www-servers/orion/ChangeLog
+++ b/www-servers/orion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/orion
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/ChangeLog,v 1.8 2005/03/16 13:55:30 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/ChangeLog,v 1.9 2005/06/24 22:33:04 agriffis Exp $
+
+ 24 Jun 2005; Aron Griffis <agriffis@gentoo.org> orion-2.0.1.ebuild,
+ orion-2.0.2.ebuild, orion-2.0.5.ebuild:
+ Use $IMAGE instead of $D in pkg_*. Don't call fowners in pkg_*, use chown
+ instead. In 2.0.5, move the chown from pkg_postinst to pkg_preinst so it
+ happens prior to the merge. Move pkg_preinst below src_install in the ebuild
+ since the functions are called in that order
16 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org> orion-2.0.5.ebuild:
applied parts of the patch which was suggested in #85032 by Marc Vilanova
diff --git a/www-servers/orion/orion-2.0.1.ebuild b/www-servers/orion/orion-2.0.1.ebuild
index 662ebefc6bad..fe40b618ccea 100644
--- a/www-servers/orion/orion-2.0.1.ebuild
+++ b/www-servers/orion/orion-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.1.ebuild,v 1.3 2005/01/08 01:59:21 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.1.ebuild,v 1.4 2005/06/24 22:33:04 agriffis Exp $
inherit eutils java-pkg
@@ -24,14 +24,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PV}-gentoo.patch
}
-pkg_preinst() {
- enewgroup orion
- enewuser orion -1 /bin/bash /opt/orion orion
- chown -R orion:orion ${D}/opt/${PN}
- chown -R orion:orion ${D}/var/log/${PN}
- fowners orion:orion /etc/conf.d/orion
-}
-
src_install() {
# CREATE DIRECTORIES
diropts -m0775
@@ -91,6 +83,14 @@ src_install() {
dodoc Readme.txt changes.txt
}
+pkg_preinst() {
+ enewgroup orion
+ enewuser orion -1 /bin/bash /opt/orion orion
+ chown -R orion:orion ${IMAGE}/opt/${PN}
+ chown -R orion:orion ${IMAGE}/var/log/${PN}
+ chown orion:orion ${IMAGE}/etc/conf.d/orion
+}
+
pkg_postinst() {
einfo " "
einfo " NOTICE!"
diff --git a/www-servers/orion/orion-2.0.2.ebuild b/www-servers/orion/orion-2.0.2.ebuild
index 5593086f95b6..e22ce909eb80 100644
--- a/www-servers/orion/orion-2.0.2.ebuild
+++ b/www-servers/orion/orion-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.2.ebuild,v 1.3 2005/01/08 01:59:21 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.2.ebuild,v 1.4 2005/06/24 22:33:04 agriffis Exp $
inherit eutils java-pkg
@@ -24,14 +24,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PV}-gentoo.patch
}
-pkg_preinst() {
- enewgroup orion
- enewuser orion -1 /bin/bash /opt/orion orion
- chown -R orion:orion ${D}/opt/${PN}
- chown -R orion:orion ${D}/var/log/${PN}
- fowners orion:orion /etc/conf.d/orion
-}
-
src_install() {
# CREATE DIRECTORIES
diropts -m0775
@@ -91,6 +83,14 @@ src_install() {
dodoc Readme.txt changes.txt
}
+pkg_preinst() {
+ enewgroup orion
+ enewuser orion -1 /bin/bash /opt/orion orion
+ chown -R orion:orion ${IMAGE}/opt/${PN}
+ chown -R orion:orion ${IMAGE}/var/log/${PN}
+ chown orion:orion ${IMAGE}/etc/conf.d/orion
+}
+
pkg_postinst() {
einfo " "
einfo " NOTICE!"
diff --git a/www-servers/orion/orion-2.0.5.ebuild b/www-servers/orion/orion-2.0.5.ebuild
index 57dd00b72bac..4d05db0b81f4 100644
--- a/www-servers/orion/orion-2.0.5.ebuild
+++ b/www-servers/orion/orion-2.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.5.ebuild,v 1.3 2005/03/16 13:55:30 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.5.ebuild,v 1.4 2005/06/24 22:33:04 agriffis Exp $
inherit eutils java-pkg
@@ -24,11 +24,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PV}-gentoo.patch
}
-pkg_preinst() {
- enewgroup orion
- enewuser orion -1 /bin/bash /opt/orion orion
-}
-
src_install() {
# CREATE DIRECTORIES
diropts -m0755
@@ -88,12 +83,15 @@ src_install() {
dodoc Readme.txt changes.txt
}
-pkg_postinst() {
-
- chown -R orion:orion /opt/${PN} || die "Failed to chown in /opt"
- chown -R orion:orion /var/log/${PN} || die "Failed to chown in /var/log"
- chown root:root /etc/conf.d/orion
+pkg_preinst() {
+ enewgroup orion
+ enewuser orion -1 /bin/bash /opt/orion orion
+ chown -R orion:orion ${IMAGE}/opt/${PN}
+ chown -R orion:orion ${IMAGE}/var/log/${PN}
+ chown root:root ${IMAGE}/etc/conf.d/orion
+}
+pkg_postinst() {
einfo " "
einfo " NOTICE!"
einfo " User and group 'orion' have been added."