summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/mozplugger/mozplugger-1.13.2.ebuild')
-rw-r--r--www-plugins/mozplugger/mozplugger-1.13.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-plugins/mozplugger/mozplugger-1.13.2.ebuild b/www-plugins/mozplugger/mozplugger-1.13.2.ebuild
new file mode 100644
index 000000000000..cc3809f9d551
--- /dev/null
+++ b/www-plugins/mozplugger/mozplugger-1.13.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozplugger/mozplugger-1.13.2.ebuild,v 1.1 2010/04/05 13:27:27 ssuominen Exp $
+
+EAPI=2
+inherit nsplugins toolchain-funcs
+
+DESCRIPTION="Streaming media plugin for Mozilla, based on netscape-plugger"
+SRC_URI="http://mozplugger.mozdev.org/files/${P}.tar.gz"
+HOMEPAGE="http://mozplugger.mozdev.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ net-libs/xulrunner:1.9"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ XCFLAGS="-fPIC -Wall" \
+ COMMON_LDFLAGS="${LDFLAGS}" \
+ all || die
+}
+
+src_install() {
+ emake root="${D}" install || die
+ src_mv_plugins /usr/lib/mozilla/plugins
+ dodoc ChangeLog README
+}