summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/mozilla-launcher/mozilla-launcher-1.57.ebuild')
-rw-r--r--www-client/mozilla-launcher/mozilla-launcher-1.57.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-client/mozilla-launcher/mozilla-launcher-1.57.ebuild b/www-client/mozilla-launcher/mozilla-launcher-1.57.ebuild
new file mode 100644
index 000000000000..dc6e7088fc35
--- /dev/null
+++ b/www-client/mozilla-launcher/mozilla-launcher-1.57.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.57.ebuild,v 1.1 2008/01/01 14:02:16 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE="http://sources.gentoo.org/viewcvs.py/gentoo-src/mozilla-launcher/"
+SRC_URI="mirror://gentoo/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="x11-apps/xdpyinfo"
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher || die
+}
+
+pkg_postinst() {
+ local f
+
+ find "${ROOT}/usr/bin" -maxdepth 1 -type l | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}