summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/kazehakase/files/kazehakase-0.5.4-xulrunner19.patch')
-rw-r--r--www-client/kazehakase/files/kazehakase-0.5.4-xulrunner19.patch112
1 files changed, 112 insertions, 0 deletions
diff --git a/www-client/kazehakase/files/kazehakase-0.5.4-xulrunner19.patch b/www-client/kazehakase/files/kazehakase-0.5.4-xulrunner19.patch
new file mode 100644
index 000000000000..5ac35b205706
--- /dev/null
+++ b/www-client/kazehakase/files/kazehakase-0.5.4-xulrunner19.patch
@@ -0,0 +1,112 @@
+diff -urN kazehakase-0.5.4.orig/ext/ruby/Makefile.in kazehakase-0.5.4/ext/ruby/Makefile.in
+--- kazehakase-0.5.4.orig/ext/ruby/Makefile.in 2008-03-29 10:20:54.000000000 +0200
++++ kazehakase-0.5.4/ext/ruby/Makefile.in 2008-06-19 03:32:03.000000000 +0300
+@@ -306,7 +306,6 @@
+ top_srcdir = @top_srcdir@
+ ext_LTLIBRARIES = ruby.la
+ INCLUDES = \
+- $(MOZILLA_COMPONENT_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS) \
+ $(RUBY_CFLAGS) \
+@@ -354,7 +353,6 @@
+ $(GTK_LIBS) \
+ $(LIBGNUTLS_LIBS) \
+ $(RUBY_LIBS) \
+- $(MOZILLA_COMPONENT_LIBS) \
+ $(top_builddir)/src/libkazehakase.la
+
+ all: all-am
+diff -urN kazehakase-0.5.4.orig/ext/ruby/Makefile.am kazehakase-0.5.4/ext/ruby/Makefile.am
+--- kazehakase-0.5.4.orig/ext/ruby/Makefile.am 2008-03-29 10:20:42.000000000 +0200
++++ kazehakase-0.5.4/ext/ruby/Makefile.am 2008-06-19 03:32:04.000000000 +0300
+@@ -8,7 +8,6 @@
+ -DG_DISABLE_DEPRECATED=1
+
+ INCLUDES = \
+- $(MOZILLA_COMPONENT_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS) \
+ $(RUBY_CFLAGS) \
+@@ -63,5 +62,4 @@
+ $(GTK_LIBS) \
+ $(LIBGNUTLS_LIBS) \
+ $(RUBY_LIBS) \
+- $(MOZILLA_COMPONENT_LIBS) \
+ $(top_builddir)/src/libkazehakase.la
+diff -urN kazehakase-0.5.4.orig/module/embed/gecko/mozilla.cpp kazehakase-0.5.4/module/embed/gecko/mozilla.cpp
+--- kazehakase-0.5.4.orig/module/embed/gecko/mozilla.cpp 2008-03-29 10:20:40.000000000 +0200
++++ kazehakase-0.5.4/module/embed/gecko/mozilla.cpp 2008-06-19 03:32:04.000000000 +0300
+@@ -25,6 +25,7 @@
+
+ #define MOZILLA_CLIENT
+
++#include <mozilla-config.h>
+ #include <gtkmozembed.h>
+ #include <nsXPCOM.h>
+ #include <nsIGenericFactory.h>
+@@ -50,6 +51,10 @@
+ #include <gtkmozembed_glue.cpp>
+ #include <nsGenericFactory.h>
+ #endif
++#ifdef HAVE_GECKO_1_9
++#include <nsComponentManagerUtils.h>
++#endif
++
+
+ NS_GENERIC_FACTORY_CONSTRUCTOR(KzFilePicker)
+ NS_GENERIC_FACTORY_CONSTRUCTOR(KzContentHandler)
+diff -urN kazehakase-0.5.4.orig/module/embed/gecko/kz-mozlauncher.cpp kazehakase-0.5.4/module/embed/gecko/kz-mozlauncher.cpp
+--- kazehakase-0.5.4.orig/module/embed/gecko/kz-mozlauncher.cpp 2008-03-29 10:20:40.000000000 +0200
++++ kazehakase-0.5.4/module/embed/gecko/kz-mozlauncher.cpp 2008-06-19 03:32:04.000000000 +0300
+@@ -76,6 +76,9 @@
+ nsISupports *aWindowContext,
+ const PRUnichar *aDefaultFile,
+ const PRUnichar *aSuggestedFileExtension,
++#ifdef HAVE_GECKO_1_9
++ PRBool aForcePrompt,
++#endif
+ nsILocalFile **_retval)
+ {
+ nsresult rv;
+diff -urN kazehakase-0.5.4.orig/module/embed/gecko/gtkmozembed/nsProfileDirServiceProvider2.cpp kazehakase-0.5.4/module/embed/gecko/gtkmozembed/nsProfileDirServiceProvider2.cpp
+--- kazehakase-0.5.4.orig/module/embed/gecko/gtkmozembed/nsProfileDirServiceProvider2.cpp 2008-03-29 10:20:40.000000000 +0200
++++ kazehakase-0.5.4/module/embed/gecko/gtkmozembed/nsProfileDirServiceProvider2.cpp 2008-06-19 03:32:04.000000000 +0300
+@@ -306,26 +306,6 @@
+ rv = EnsureProfileFileExists(localFile, domainDir);
+ }
+ }
+- else if (strcmp(prop, NS_APP_MAIL_50_DIR) == 0) {
+- rv = domainDir->Clone(getter_AddRefs(localFile));
+- if (NS_SUCCEEDED(rv))
+- rv = localFile->AppendNative(MAIL_DIR_50_NAME);
+- }
+- else if (strcmp(prop, NS_APP_IMAP_MAIL_50_DIR) == 0) {
+- rv = domainDir->Clone(getter_AddRefs(localFile));
+- if (NS_SUCCEEDED(rv))
+- rv = localFile->AppendNative(IMAP_MAIL_DIR_50_NAME);
+- }
+- else if (strcmp(prop, NS_APP_NEWS_50_DIR) == 0) {
+- rv = domainDir->Clone(getter_AddRefs(localFile));
+- if (NS_SUCCEEDED(rv))
+- rv = localFile->AppendNative(NEWS_DIR_50_NAME);
+- }
+- else if (strcmp(prop, NS_APP_MESSENGER_FOLDER_CACHE_50_DIR) == 0) {
+- rv = domainDir->Clone(getter_AddRefs(localFile));
+- if (NS_SUCCEEDED(rv))
+- rv = localFile->AppendNative(MSG_FOLDER_CACHE_DIR_50_NAME);
+- }
+ else if (strcmp(prop, NS_APP_STORAGE_50_FILE) == 0) {
+ rv = domainDir->Clone(getter_AddRefs(localFile));
+ if (NS_SUCCEEDED(rv))
+@@ -518,10 +498,6 @@
+ (void) directoryService->Undefine(NS_APP_BOOKMARKS_50_FILE);
+ (void) directoryService->Undefine(NS_APP_DOWNLOADS_50_FILE);
+ (void) directoryService->Undefine(NS_APP_SEARCH_50_FILE);
+- (void) directoryService->Undefine(NS_APP_MAIL_50_DIR);
+- (void) directoryService->Undefine(NS_APP_IMAP_MAIL_50_DIR);
+- (void) directoryService->Undefine(NS_APP_NEWS_50_DIR);
+- (void) directoryService->Undefine(NS_APP_MESSENGER_FOLDER_CACHE_50_DIR);
+
+ return NS_OK;
+ }