summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/phpwiki/phpwiki-1.3.11_p1.ebuild')
-rw-r--r--www-apps/phpwiki/phpwiki-1.3.11_p1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/phpwiki/phpwiki-1.3.11_p1.ebuild b/www-apps/phpwiki/phpwiki-1.3.11_p1.ebuild
new file mode 100644
index 000000000000..d33cfa49dbdb
--- /dev/null
+++ b/www-apps/phpwiki/phpwiki-1.3.11_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.3.11_p1.ebuild,v 1.1 2005/11/27 16:03:16 rl03 Exp $
+
+inherit webapp
+
+MY_P=${P/_p/p}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="PhpWiki is a WikiWikiWeb clone in PHP"
+HOMEPAGE="http://phpwiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/php
+ net-www/apache"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -f Makefile LICENSE
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -pPR * ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/{doc,schemas,README,INSTALL,TODO,UPGRADING}
+
+ dodoc README INSTALL TODO UPGRADING doc/* schemas/*
+
+ # Create config file from distribution default, and fix up invalid defaults
+ cd ${D}/${MY_HTDOCSDIR}/config
+ sed "s:;DEBUG = 1:DEBUG = 0:" config-dist.ini > config.ini
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-1.3-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/config/config.ini
+
+ webapp_src_install
+}