summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_wsgi')
-rw-r--r--www-apache/mod_wsgi/ChangeLog11
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-3.4-r1.ebuild (renamed from www-apache/mod_wsgi/mod_wsgi-3.3.ebuild)21
2 files changed, 18 insertions, 14 deletions
diff --git a/www-apache/mod_wsgi/ChangeLog b/www-apache/mod_wsgi/ChangeLog
index ee8855505f26..207503e771ba 100644
--- a/www-apache/mod_wsgi/ChangeLog
+++ b/www-apache/mod_wsgi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_wsgi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/ChangeLog,v 1.36 2012/11/27 19:37:31 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/ChangeLog,v 1.37 2013/10/15 09:52:12 djc Exp $
+
+*mod_wsgi-3.4-r1 (15 Oct 2013)
+
+ 15 Oct 2013; Dirkjan Ochtman <djc@gentoo.org> -mod_wsgi-3.3.ebuild,
+ +mod_wsgi-3.4-r1.ebuild:
+ Remove old version, support python-single-r1 (bug 450022, thanks to Joachim
+ Breur <gentoo@jmbreuer.net> for the patch).
27 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop apache herd as discussed in http://www.gossamer-
diff --git a/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild b/www-apache/mod_wsgi/mod_wsgi-3.4-r1.ebuild
index e30522e0fffa..f034d3237459 100644
--- a/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild
+++ b/www-apache/mod_wsgi/mod_wsgi-3.4-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/mod_wsgi-3.3.ebuild,v 1.5 2011/04/22 21:58:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/mod_wsgi-3.4-r1.ebuild,v 1.1 2013/10/15 09:52:12 djc Exp $
-EAPI="3"
-PYTHON_DEPEND="*"
-PYTHON_USE_WITH="threads"
+EAPI="5"
-inherit apache-module eutils python
+PYTHON_COMPAT=( python2_6 python2_7 python3_1 python3_2 python3_3 )
+PYTHON_REQ_USE="threads"
+
+inherit apache-module eutils python-single-r1
DESCRIPTION="An Apache2 module for running Python WSGI applications."
HOMEPAGE="http://code.google.com/p/modwsgi/"
@@ -14,7 +15,7 @@ SRC_URI="http://modwsgi.googlecode.com/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=""
@@ -27,12 +28,8 @@ DOCFILES="README"
need_apache2
-src_prepare() {
- epatch "${FILESDIR}/${P}-python-3.2.patch"
-}
-
src_configure() {
- econf --with-apxs=${APXS}
+ econf --with-apxs=${APXS} --with-python=${PYTHON}
}
src_compile() {