summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild')
-rw-r--r--www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild
new file mode 100644
index 000000000000..477c6dada1c9
--- /dev/null
+++ b/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_tkt/mod_auth_tkt-2.1.0.ebuild,v 1.1 2009/09/17 07:45:27 hollow Exp $
+
+# test suite is completely broken
+RESTRICT="test"
+
+inherit apache-module
+
+DESCRIPTION="Apache module for cookie based authentication"
+HOMEPAGE="http://www.openfusion.com.au/labs/mod_auth_tkt/"
+SRC_URI="http://www.openfusion.com.au/labs/dist/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_TKT"
+
+DOCFILES="README"
+
+need_apache2_2
+
+src_compile() {
+ ./configure --apachever=2.2 --apxs=${APXS} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ apache-module_src_install
+ pod2man --section=5 --release=${PV} doc/${PN}.{pod,5}
+ doman doc/${PN}.5
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+ einfo "See 'man mod_auth_tkt' for details on the individual directives."
+ einfo "Remember to change shared secret 'TKTAuthSecret' before using!"
+ einfo
+}