summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-imaging/ChangeLog5
-rw-r--r--virtual/python-imaging/python-imaging-1.ebuild11
2 files changed, 6 insertions, 10 deletions
diff --git a/virtual/python-imaging/ChangeLog b/virtual/python-imaging/ChangeLog
index c6682812ea2b..48ea3f596dd5 100644
--- a/virtual/python-imaging/ChangeLog
+++ b/virtual/python-imaging/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for virtual/python-imaging
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-imaging/ChangeLog,v 1.3 2013/06/10 15:56:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-imaging/ChangeLog,v 1.4 2013/09/05 13:55:39 mgorny Exp $
+
+ 05 Sep 2013; Michał Górny <mgorny@gentoo.org> python-imaging-1.ebuild:
+ Drop stale conditionals after py2.5 removal.
10 Jun 2013; Mike Gilbert <floppym@gentoo.org> python-imaging-1.ebuild:
Add a required use constraint to make the situation with python2.5 and python3
diff --git a/virtual/python-imaging/python-imaging-1.ebuild b/virtual/python-imaging/python-imaging-1.ebuild
index 091b5ac3e4ea..08b9201722f9 100644
--- a/virtual/python-imaging/python-imaging-1.ebuild
+++ b/virtual/python-imaging/python-imaging-1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-imaging/python-imaging-1.ebuild,v 1.3 2013/06/10 15:56:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-imaging/python-imaging-1.ebuild,v 1.4 2013/09/05 13:55:39 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
inherit python-r1
@@ -15,15 +15,8 @@ LICENSE=""
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="tk"
-REQUIRED_USE="
- python_targets_python2_5? (
- !python_targets_python3_2
- !python_targets_python3_3
- )
-"
RDEPEND="
- python_targets_python2_5? ( dev-python/imaging[tk?,python_targets_python2_5(-)] )
python_targets_python2_6? ( || (
dev-python/pillow[tk?,python_targets_python2_6(-)]
dev-python/imaging[tk?,python_targets_python2_6(-)]