summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libvserver/libvserver-1.0.2.ebuild')
-rw-r--r--sys-libs/libvserver/libvserver-1.0.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-libs/libvserver/libvserver-1.0.2.ebuild b/sys-libs/libvserver/libvserver-1.0.2.ebuild
index 5676df75eee9..4a1d691ba1ef 100644
--- a/sys-libs/libvserver/libvserver-1.0.2.ebuild
+++ b/sys-libs/libvserver/libvserver-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvserver/libvserver-1.0.2.ebuild,v 1.1 2006/01/21 19:46:45 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libvserver/libvserver-1.0.2.ebuild,v 1.2 2006/01/21 19:56:16 hollow Exp $
DESCRIPTION="Linux-VServer syscall library"
HOMEPAGE="http://dev.croup.de/proj/libvserver"
@@ -9,9 +9,14 @@ SRC_URI="http://dev.gentoo.org/~hollow/libvserver/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="diet"
-DEPEND=""
+DEPEND="diet? ( >=dev-libs/dietlibc-0.28 )"
+
+src_compile() {
+ econf $(use_enable diet dietlibc) || die "econf failed"
+ emake || die "emake failed"
+}
src_install() {
make DESTDIR="${D}" install || die "make install failed"