summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog7
-rw-r--r--sys-libs/libcxx/files/cxxrt.patch26
-rw-r--r--sys-libs/libcxx/files/multilib.patch15
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20130218.ebuild68
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20130531-r1.ebuild133
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20130531.ebuild101
6 files changed, 6 insertions, 344 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 69b6e7675c19..d17746ff91ce 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.33 2013/08/26 21:20:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.34 2013/08/26 21:23:46 aballier Exp $
+
+ 26 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ -libcxx-0.0_p20130218.ebuild, -libcxx-0.0_p20130531.ebuild,
+ -libcxx-0.0_p20130531-r1.ebuild, -files/cxxrt.patch, -files/multilib.patch:
+ remove old
26 Aug 2013; Alexis Ballier <aballier@gentoo.org>
libcxx-0.0_p20130725.ebuild, libcxx-9999.ebuild:
diff --git a/sys-libs/libcxx/files/cxxrt.patch b/sys-libs/libcxx/files/cxxrt.patch
deleted file mode 100644
index c64d8b3b35d7..000000000000
--- a/sys-libs/libcxx/files/cxxrt.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: lib/CMakeLists.txt
-===================================================================
---- lib/CMakeLists.txt (revision 157576)
-+++ lib/CMakeLists.txt (working copy)
-@@ -36,7 +36,7 @@
- append_if(libraries LIBCXX_HAS_C_LIB c)
- append_if(libraries LIBCXX_HAS_M_LIB m)
- append_if(libraries LIBCXX_HAS_RT_LIB rt)
--append_if(libraries LIBCXX_HAS_GCC_S_LIB gcc_s)
-+append_if(libraries LIBCXX_HAS_LIBCXXRT cxxrt)
-
- target_link_libraries(cxx ${libraries})
-
-Index: cmake/config-ix.cmake
-===================================================================
---- cmake/config-ix.cmake (revision 157576)
-+++ cmake/config-ix.cmake (working copy)
-@@ -26,7 +26,7 @@
- check_library_exists(c printf "" LIBCXX_HAS_C_LIB)
- check_library_exists(m ccos "" LIBCXX_HAS_M_LIB)
- check_library_exists(rt clock_gettime "" LIBCXX_HAS_RT_LIB)
--check_library_exists(gcc_s __gcc_personality_v0 "" LIBCXX_HAS_GCC_S_LIB)
-+check_library_exists(cxxrt __cxa_get_globals "" LIBCXX_HAS_LIBCXXRT)
-
- # Check C++0x features
- if (LIBCXX_ENABLE_CXX0X)
diff --git a/sys-libs/libcxx/files/multilib.patch b/sys-libs/libcxx/files/multilib.patch
deleted file mode 100644
index eb177f92734b..000000000000
--- a/sys-libs/libcxx/files/multilib.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: libcxx-0.0_p20120523/lib/CMakeLists.txt
-===================================================================
---- libcxx-0.0_p20120523.orig/lib/CMakeLists.txt
-+++ libcxx-0.0_p20120523/lib/CMakeLists.txt
-@@ -54,8 +54,8 @@ set_target_properties(cxx
- )
-
- install(TARGETS cxx
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
-+ LIBRARY DESTINATION lib${LIB_SUFFIX}
-+ ARCHIVE DESTINATION lib${LIB_SUFFIX}
- )
-
- install(DIRECTORY ../include/
diff --git a/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild b/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild
deleted file mode 100644
index 897cdf50796d..000000000000
--- a/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild,v 1.1 2013/02/18 14:30:06 aballier Exp $
-
-EAPI=4
-
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-
-inherit cmake-utils ${SCM} base flag-o-matic
-
-DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI=""
-fi
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-else
- KEYWORDS=""
-fi
-IUSE=""
-
-RDEPEND="sys-libs/libcxxrt"
-DEPEND="${RDEPEND}
- sys-devel/clang
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}/multilib.patch"
- "${FILESDIR}/cxxrt.patch" )
-DOCS=( "CREDITS.TXT" )
-
-src_prepare() {
- base_src_prepare
-}
-
-src_configure() {
- append-cppflags "-I/usr/include/libcxxrt -DLIBCXXRT"
- # Needs to be built with clang. gcc-4.6.3 fails at least.
- # TODO: cross-compile ?
- export CC=clang
- export CXX=clang++
- cmake-utils_src_configure
-}
-
-# Tests fail for now, if anybody is able to fix them, help is very welcome.
-src_test() {
- cd "${S}/test"
- LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/lib:${LD_LIBRARY_PATH}" \
- CC="clang++" \
- HEADER_INCLUDE="-I${S}/include" \
- SOURCE_LIB="-L${CMAKE_BUILD_DIR}/lib" \
- ./testit || die
-}
-
-pkg_postinst() {
- elog "This package (${PN}) is mainly intended as a replacement for the C++"
- elog "standard library when using clang."
- elog "To use it, instead of libstdc++, use:"
- elog " clang++ -stdlib=libc++"
- elog "to compile your C++ programs."
-}
diff --git a/sys-libs/libcxx/libcxx-0.0_p20130531-r1.ebuild b/sys-libs/libcxx/libcxx-0.0_p20130531-r1.ebuild
deleted file mode 100644
index db229d286dfe..000000000000
--- a/sys-libs/libcxx/libcxx-0.0_p20130531-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20130531-r1.ebuild,v 1.4 2013/07/02 21:56:24 aballier Exp $
-
-EAPI=5
-
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-
-inherit cmake-utils ${SCM} base flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI=""
-fi
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-else
- KEYWORDS=""
-fi
-IUSE="elibc_glibc +libcxxrt static-libs"
-
-RDEPEND="libcxxrt? ( >=sys-libs/libcxxrt-0.0_p20130530[static-libs?] )
- !libcxxrt? ( sys-devel/gcc[cxx] )"
-DEPEND="${RDEPEND}
- sys-devel/clang
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}/multilib.patch" )
-DOCS=( "CREDITS.TXT" )
-
-src_prepare() {
- use libcxxrt && PATCHES+=( "${FILESDIR}/cxxrt.patch" )
- base_src_prepare
-}
-
-src_configure() {
- local mycmakeargs_base=( )
- if use libcxxrt ; then
- mycmakeargs_base=(
- -DLIBCXX_CXX_ABI=libcxxrt
- -DLIBCXX_LIBCXXRT_INCLUDE_PATHS="/usr/include/libcxxrt/"
- )
- else
- # Very hackish, see $HOMEPAGE
- # If someone has a clever idea, please share it!
- local includes="$(echo | "$(tc-getCXX)" -Wp,-v -x c++ - -fsyntax-only 2>&1 | grep -C 2 '#include.*<...>' | tail -n 2 | tr '\n' ';' | tr -d ' ')"
- mycmakeargs_base=(
- -DLIBCXX_CXX_ABI=libsupc++
- -DLIBCXX_LIBSUPCXX_INCLUDE_PATHS="${includes}"
- )
- fi
-
- # Needs to be built with clang. gcc-4.6.3 fails at least.
- # TODO: cross-compile ?
- export CC="clang"
- export CXX="clang++"
-
- if use static-libs ; then
- local mycmakeargs=( "${mycmakeargs_base[@]}" "-DLIBCXX_ENABLE_SHARED=OFF" )
- BUILD_DIR="${S}_static" cmake-utils_src_configure
- fi
- local mycmakeargs=( "${mycmakeargs_base[@]}" )
- BUILD_DIR="${S}_shared" cmake-utils_src_configure
-}
-
-src_compile() {
- use static-libs && BUILD_DIR="${S}_static" cmake-utils_src_compile
- BUILD_DIR="${S}_shared" cmake-utils_src_compile
-}
-
-# Tests fail for now, if anybody is able to fix them, help is very welcome.
-src_test() {
- cd "${S}/test"
- LD_LIBRARY_PATH="${S}_shared/lib:${LD_LIBRARY_PATH}" \
- CC="clang++" \
- HEADER_INCLUDE="-I${S}/include" \
- SOURCE_LIB="-L${S}_shared/lib" \
- LIBS="-lm" \
- ./testit || die
-}
-
-gen_static_ldscript() {
- if use libcxxrt ; then
- # Move it first.
- mv "${D}/${EPREFIX}/usr/$(get_libdir)/libc++.a" "${D}/${EPREFIX}/usr/$(get_libdir)/libc++_static.a" || die
-
- # Generate libc++.a ldscript for inclusion of its dependencies so that
- # clang++ -stdlib=libc++ -static works out of the box.
- # Taken from toolchain-funcs.eclass:
- local output_format
- output_format=$($(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wl,--verbose 2>&1 | sed -n 's/^OUTPUT_FORMAT("\([^"]*\)",.*/\1/p')
- [[ -n ${output_format} ]] && output_format="OUTPUT_FORMAT ( ${output_format} )"
-
- local deps="${EPREFIX}/usr/$(get_libdir)/libc++_static.a ${EPREFIX}/usr/$(get_libdir)/libcxxrt.a"
- # On Linux/glibc it does not link without libpthread or libdl. It is
- # fine on FreeBSD.
- use elibc_glibc && deps="${deps} ${EPREFIX}/usr/$(get_libdir)/libpthread.a ${EPREFIX}/usr/$(get_libdir)/libdl.a"
-
- cat > "${D}/${EPREFIX}/usr/$(get_libdir)/libc++.a" <<-END_LDSCRIPT
-/* GNU ld script
- Include libc++.a dependencies for 'clang++ -stdlib=libc++ -static' to work
- out of the box.
- */
-${output_format}
-GROUP ( ${deps} )
-END_LDSCRIPT
- fi
- # TODO: Generate a libc++.a ldscript when building against libsupc++
-}
-
-src_install() {
- if use static-libs ; then
- BUILD_DIR="${S}_static" cmake-utils_src_install
- gen_static_ldscript
- fi
- BUILD_DIR="${S}_shared" cmake-utils_src_install
-}
-
-pkg_postinst() {
- elog "This package (${PN}) is mainly intended as a replacement for the C++"
- elog "standard library when using clang."
- elog "To use it, instead of libstdc++, use:"
- elog " clang++ -stdlib=libc++"
- elog "to compile your C++ programs."
-}
diff --git a/sys-libs/libcxx/libcxx-0.0_p20130531.ebuild b/sys-libs/libcxx/libcxx-0.0_p20130531.ebuild
deleted file mode 100644
index f5ffc07e4a61..000000000000
--- a/sys-libs/libcxx/libcxx-0.0_p20130531.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20130531.ebuild,v 1.1 2013/05/31 15:57:41 aballier Exp $
-
-EAPI=5
-
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-
-inherit cmake-utils ${SCM} base flag-o-matic toolchain-funcs
-
-DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI=""
-fi
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-else
- KEYWORDS=""
-fi
-IUSE="+libcxxrt static-libs"
-
-RDEPEND="libcxxrt? ( >=sys-libs/libcxxrt-0.0_p20130530[static-libs?] )
- !libcxxrt? ( sys-devel/gcc[cxx] )"
-DEPEND="${RDEPEND}
- sys-devel/clang
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}/multilib.patch" )
-DOCS=( "CREDITS.TXT" )
-
-src_prepare() {
- use libcxxrt && PATCHES+=( "${FILESDIR}/cxxrt.patch" )
- base_src_prepare
-}
-
-src_configure() {
- local mycmakeargs_base=( )
- if use libcxxrt ; then
- mycmakeargs_base=(
- -DLIBCXX_CXX_ABI=libcxxrt
- -DLIBCXX_LIBCXXRT_INCLUDE_PATHS="/usr/include/libcxxrt/"
- )
- else
- # Very hackish, see $HOMEPAGE
- # If someone has a clever idea, please share it!
- local includes="$(echo | "$(tc-getCXX)" -Wp,-v -x c++ - -fsyntax-only 2>&1 | grep -C 2 '#include.*<...>' | tail -n 2 | tr '\n' ';' | tr -d ' ')"
- mycmakeargs_base=(
- -DLIBCXX_CXX_ABI=libsupc++
- -DLIBCXX_LIBSUPCXX_INCLUDE_PATHS="${includes}"
- )
- fi
-
- # Needs to be built with clang. gcc-4.6.3 fails at least.
- # TODO: cross-compile ?
- export CC=clang
- export CXX=clang++
-
- if use static-libs ; then
- local mycmakeargs=( "${mycmakeargs_base[@]}" "-DLIBCXX_ENABLE_SHARED=OFF" )
- BUILD_DIR="${S}_static" cmake-utils_src_configure
- fi
- local mycmakeargs=( "${mycmakeargs_base[@]}" )
- BUILD_DIR="${S}_shared" cmake-utils_src_configure
-}
-
-src_compile() {
- use static-libs && BUILD_DIR="${S}_static" cmake-utils_src_compile
- BUILD_DIR="${S}_shared" cmake-utils_src_compile
-}
-
-# Tests fail for now, if anybody is able to fix them, help is very welcome.
-src_test() {
- cd "${S}/test"
- LD_LIBRARY_PATH="${S}_shared/lib:${LD_LIBRARY_PATH}" \
- CC="clang++" \
- HEADER_INCLUDE="-I${S}/include" \
- SOURCE_LIB="-L${S}_shared/lib" \
- LIBS="-lm" \
- ./testit || die
-}
-
-src_install() {
- use static-libs && BUILD_DIR="${S}_static" cmake-utils_src_install
- BUILD_DIR="${S}_shared" cmake-utils_src_install
-}
-
-pkg_postinst() {
- elog "This package (${PN}) is mainly intended as a replacement for the C++"
- elog "standard library when using clang."
- elog "To use it, instead of libstdc++, use:"
- elog " clang++ -stdlib=libc++"
- elog "to compile your C++ programs."
-}