summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/ppc-sources/ppc-sources-2.4.22-r1.ebuild')
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.22-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.22-r1.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.22-r1.ebuild
new file mode 100644
index 000000000000..6683f164e52a
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.22-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.22-r1.ebuild,v 1.1 2003/09/17 10:29:32 trance Exp $
+
+IUSE=""
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+MY_R=`echo $PR | sed "s:r:ben:g"`
+
+DESCRIPTION="PowerPC kernel tree based on benh's patches, -r corresponds to ben{r} versioning"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://www.kernel.org/pub/linux/kernel/people/benh/patch-${OKV}-${MY_R}.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/benh/"
+KEYWORDS="-x86 ~ppc -sparc -alpha"
+PROVIDE="virtual/linux-sources"
+LICENSE="GPL-2"
+SLOT="${KV}"
+DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} ${PF} || die
+
+ cd ${PF}
+ patch -p1 < ${WORKDIR}/patch-${OKV}-${MY_R} || die "patch failed"
+
+ use xfs && ( ewarn "XFS is no longer included in ppc-sources!" )
+}
+
+src_install() {
+ dodir /usr/src
+ cd ${S}
+ rm ${WORKDIR}/patch-${OKV}-${MY_R}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+}