summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-fix.patch')
-rw-r--r--sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-fix.patch b/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-fix.patch
index a3f009e0dc86..bf3acafad4df 100644
--- a/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-fix.patch
+++ b/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-fix.patch
@@ -41,3 +41,14 @@
endif
ifdef CONFIG_CPU_NEVADA
GCCFLAGS += -mcpu=r8000 -mips3 -mmad
+--- arch/mips64/Makefile.orig 2003-10-15 05:37:01.000000000 -0400
++++ arch/mips64/Makefile 2003-10-15 05:37:44.000000000 -0400
+@@ -288,7 +288,7 @@ endif
+ # convert to ECOFF using elf2ecoff.
+ #
+ ifdef CONFIG_BOOT_ELF32
+-GCCFLAGS += -Wa,-32 $(shell if $(CC) -Wa,-mgp64 -c -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "-Wa,-mgp64"; fi)
++GCCFLAGS += -Wa,-mabi=o64 $(shell if $(CC) -Wa,-mgp64 -c -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "-Wa,-mgp64"; fi)
+ LINKFLAGS += -T arch/mips64/ld.script.elf32
+ endif
+ #