summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.4.26-r1.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.4.26-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.4.26-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.4.26-r1.ebuild
new file mode 100644
index 000000000000..28a6765d547d
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.4.26-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.4.26-r1.ebuild,v 1.1 2004/06/22 21:31:44 scox Exp $
+
+IUSE="selinux"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+HGPV=26.0
+HGPV_SRC="http://dev.gentoo.org/~scox/kernels/v2.4/hardened-patches-${KV_MAJOR}.${KV_MINOR}-${HGPV}.tar.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+
+# According to the patchset numbering scheme, 12xx patches are grsec related
+# while 13xx are SELinux related.
+
+if [ "`use selinux`" ]; then
+ UNIPATCH_EXCLUDE="12"
+else
+ UNIPATCH_EXCLUDE="13"
+fi
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${KV_MAJOR}.${KV_MINOR}-${HGPV}.tar.bz2
+ ${FILESDIR}/${OKV}*.patch"
+UNIPATCH_DOCS="${WORKDIR}/patches/hardened-patches-${KV_MAJOR}.${KV_MINOR}-${HGPV}/0000_README"
+
+DESCRIPTION="Hardened sources for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+
+SRC_URI="${KERNEL_URI} ${HGPV_SRC}"
+KEYWORDS="x86 -ppc"
+
+pkg_postinst() {
+ postinst_sources
+}