summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.1.ebuild
deleted file mode 100644
index 173253b075e2..000000000000
--- a/sys-fs/squashfs-tools/squashfs-tools-4.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.1.ebuild,v 1.3 2010/11/14 13:49:59 jlec Exp $
-
-EAPI="2"
-
-inherit toolchain-funcs eutils
-
-MY_PV=${PV}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="+gzip +lzma lzo xattr"
-
-RDEPEND="gzip? ( sys-libs/zlib )
- lzma? ( app-arch/xz-utils )
- lzo? ( dev-libs/lzo )
- !lzma? ( !lzo? ( sys-libs/zlib ) )
- xattr? ( sys-apps/attr )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-
-src_prepare() {
- sed -i \
- -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
- -e '/^LIBS =/s:$: $(LDFLAGS):' \
- Makefile || die
-}
-
-use_sed() {
- local u=$1 s="${2:-`echo $1 | tr '[:lower:]' '[:upper:]'`}_SUPPORT"
- printf '/^#?%s =/%s\n' "${s}" \
- "$(use $u && echo s:.*:${s}=1: || echo d)"
-}
-src_configure() {
- tc-export CC
- local def=`usev gzip || usev lzma || usev lzo || echo gzip`
- sed -i -r \
- -e "/^COMP_DEFAULT =/s:=.*:= ${def}:" \
- -e "$(use_sed gzip)" \
- -e "$(use_sed lzma xz)" \
- -e "$(use_sed lzo)" \
- -e "$(use_sed xattr)" \
- Makefile || die
-}
-
-src_install() {
- dobin mksquashfs unsquashfs || die
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README || die
-}
-
-pkg_postinst() {
- ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
-}