summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
deleted file mode 100644
index cded1990e86f..000000000000
--- a/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild,v 1.2 2010/11/14 13:49:59 jlec Exp $
-
-inherit toolchain-funcs eutils
-
-MY_PV=${PV}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
-
-RDEPEND="sys-libs/zlib"
-
-S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e 's:-O2:$(CFLAGS):' \
- -e '/-lz/s:$: $(LDFLAGS):' \
- Makefile || die "sed failed"
- sed -i -e 's:get_nprocs():sysconf(_SC_NPROCESSORS_ONLN):' *.c
- epatch "${FILESDIR}"/${P}-read-ret.patch #292011
- epatch "${FILESDIR}"/${P}-progress-bar.patch #292011
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- dobin mksquashfs unsquashfs || die
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README || die
-}
-
-pkg_postinst() {
- ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
-}