summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/hfsutils/hfsutils-3.2.6-r3.ebuild')
-rw-r--r--sys-fs/hfsutils/hfsutils-3.2.6-r3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sys-fs/hfsutils/hfsutils-3.2.6-r3.ebuild b/sys-fs/hfsutils/hfsutils-3.2.6-r3.ebuild
deleted file mode 100644
index f5a7b408bc7b..000000000000
--- a/sys-fs/hfsutils/hfsutils-3.2.6-r3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsutils/hfsutils-3.2.6-r3.ebuild,v 1.9 2006/09/19 02:11:06 cardoe Exp $
-
-inherit eutils
-
-DESCRIPTION="HFS FS Access utils"
-HOMEPAGE="http://www.mars.org/home/rob/proj/hfs/"
-SRC_URI="ftp://ftp.mars.org/pub/hfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ppc ~sparc ppc64"
-IUSE="tcl tk"
-
-DEPEND="virtual/libc
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )"
-RDEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/hfsutils-3.2.6-errno.patch
-}
-
-src_compile() {
- local myconf
- use tcl && myconf="--with-tcl"
- use tk && myconf="--with-tk"
-
- econf ${myconf} || die
- emake PREFIX=/usr MANDIR=/usr/share/man || die
- cd ${S}/hfsck
- emake PREFIX=/usr MANDIR=/usr/share/man || die
-}
-
-src_install() {
- dodir /usr/bin
- dodir /usr/lib
- dodir /usr/share/man/man1
- cd ${S}
- make \
- prefix=${D}/usr \
- MANDEST=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
- cd ${S}/hfsck
- install -m0755 hfsck ${D}/usr/bin/
- cd ${S}
-}