summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/hfsplusutils')
-rw-r--r--sys-fs/hfsplusutils/ChangeLog6
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch11
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild27
3 files changed, 35 insertions, 9 deletions
diff --git a/sys-fs/hfsplusutils/ChangeLog b/sys-fs/hfsplusutils/ChangeLog
index 579976d029a3..da80ad35bcb7 100644
--- a/sys-fs/hfsplusutils/ChangeLog
+++ b/sys-fs/hfsplusutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/hfsplusutils
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/ChangeLog,v 1.8 2007/01/04 18:23:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/ChangeLog,v 1.9 2007/01/08 22:21:44 josejx Exp $
+
+ 08 Jan 2007; Joseph Jezak <josejx@gentoo.org>
+ +files/hfsplusutils-1.0.4-string.patch, hfsplusutils-1.0.4-r1.ebuild:
+ Added fix for bug #160975, thanks to Ed Catmur for reporting.
04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
hfsplusutils-1.0.4-r1.ebuild:
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch
new file mode 100644
index 000000000000..2602876a1127
--- /dev/null
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-string.patch
@@ -0,0 +1,11 @@
+--- libhfsp/src/unicode.c.bak 2007-01-08 17:14:44.000000000 -0500
++++ libhfsp/src/unicode.c 2007-01-08 17:14:52.000000000 -0500
+@@ -16,7 +16,7 @@
+ #include <stdlib.h>
+ #include <endian.h>
+ #include <byteswap.h>
+-#include <linux/string.h>
++#include <string.h>
+
+ #define __USE_GNU
+ /* need wcsrtomb */
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
index 044e77a5b1c8..9d41a34ca303 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.12 2007/01/04 18:23:05 flameeyes Exp $
-
-WANT_AUTOMAKE="latest"
-WANT_AUTOCONF="latest"
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.13 2007/01/08 22:21:44 josejx Exp $
+WANT_AUTOMAKE=1.6
inherit autotools eutils libtool
MY_P="hfsplus_${PV}"
@@ -25,11 +23,24 @@ S=${WORKDIR}/hfsplus-${PV}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/hfsplusutils-1.0.4-glob.patch
- epatch ${FILESDIR}/hfsplusutils-1.0.4-errno.patch
- epatch ${FILESDIR}/hfsplusutils-1.0.4-gcc4.patch
+ epatch ${FILESDIR}/${P}-glob.patch
+ epatch ${FILESDIR}/${P}-errno.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-string.patch
+ #let's avoid the Makefile.cvs since isn't working for us
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.6
+ aclocal
+ autoconf
+ autoheader
+ automake -a
+ libtoolize --force --copy
+ elibtoolize
+}
- eautoreconf
+src_compile() {
+ econf || die
+ emake || die
}
src_install() {