summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/dd-rescue')
-rw-r--r--sys-fs/dd-rescue/ChangeLog10
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.33.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/sys-fs/dd-rescue/ChangeLog b/sys-fs/dd-rescue/ChangeLog
index ace511d56ed6..3ac63bf63e05 100644
--- a/sys-fs/dd-rescue/ChangeLog
+++ b/sys-fs/dd-rescue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dd-rescue
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.31 2012/12/16 13:52:13 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.32 2013/06/11 21:09:46 chainsaw Exp $
+
+*dd-rescue-1.33 (11 Jun 2013)
+
+ 11 Jun 2013; Tony Vroon <chainsaw@gentoo.org> +dd-rescue-1.33.ebuild:
+ Version bump, as requested by Agostino "ago" Sarubbo in bug #454534. Adds a
+ manpage and support for double, triple & quadruple data overwrite.
16 Dec 2012; Agostino Sarubbo <ago@gentoo.org> dd-rescue-1.28.ebuild:
Stable for x86, wrt bug #441530
diff --git a/sys-fs/dd-rescue/dd-rescue-1.33.ebuild b/sys-fs/dd-rescue/dd-rescue-1.33.ebuild
new file mode 100644
index 000000000000..127dd528e3e4
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.33.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.33.ebuild,v 1.1 2013/06/11 21:09:46 chainsaw Exp $
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static kernel_linux elibc_glibc"
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ # Passing LDFLAGS together with CFLAGS is not often a good idea, but
+ # in this case it makes it possible to avoid patching; after all it
+ # only builds the progrma whole, not with object files.
+ #
+ # The falloc target creates a dd_rescue binary that uses the
+ # fallocate() function, present in Kernel 2.6.23 and later and GLIBC
+ # 2.10 and later. If somebody can think of a better way to
+ # optionally use it, suggestions are welcome.
+ emake RPM_OPT_FLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ $(use kernel_linux && use elibc_glibc && echo "falloc")
+}
+
+src_install() {
+ # easier to install by hand than trying to make sense of the
+ # Makefile.
+ into /
+ dobin dd_rescue
+ dodoc README.dd_rescue
+ doman dd_rescue.1
+}