summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog7
-rw-r--r--sys-devel/autoconf/autoconf-2.63b.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 4916df7d1b6e..d41844370840 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.128 2009/01/07 20:03:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.129 2009/04/01 16:35:57 vapier Exp $
+
+*autoconf-2.63b (01 Apr 2009)
+
+ 01 Apr 2009; Mike Frysinger <vapier@gentoo.org> +autoconf-2.63b.ebuild:
+ Version bump.
07 Jan 2009; Raúl Porcel <armin76@gentoo.org> autoconf-2.63.ebuild:
alpha/ia64 stable wrt #2475067
diff --git a/sys-devel/autoconf/autoconf-2.63b.ebuild b/sys-devel/autoconf/autoconf-2.63b.ebuild
new file mode 100644
index 000000000000..b59dfda7db38
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.63b.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.63b.ebuild,v 1.1 2009/04/01 16:35:57 vapier Exp $
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS=""
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-6"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_compile() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+ # From configure output:
+ # Parallel builds via `make -jN' do not work.
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}