summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/patch/patch-2.6.1.ebuild')
-rw-r--r--sys-devel/patch/patch-2.6.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-devel/patch/patch-2.6.1.ebuild b/sys-devel/patch/patch-2.6.1.ebuild
index 690e249cd884..9ca75c025b7a 100644
--- a/sys-devel/patch/patch-2.6.1.ebuild
+++ b/sys-devel/patch/patch-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.6.1.ebuild,v 1.1 2010/01/01 07:00:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.6.1.ebuild,v 1.2 2010/01/02 03:35:04 vapier Exp $
inherit flag-o-matic
@@ -11,7 +11,11 @@ SRC_URI="mirror://gnu/patch/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="static"
+IUSE="static test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
src_compile() {
use static && append-ldflags -static