summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/patch/patch-2.5.9.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
new file mode 100644
index 000000000000..b1590e7a75ea
--- /dev/null
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.1 2003/06/18 01:38:26 seemant Exp $
+
+IUSE="build static"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="http://alpha.gnu.org/gnu/patch/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
+ ac_cv_sys_long_file_names=yes \
+ ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ if [ -z "`use static`" ]; then
+ emake || die "emake failed"
+ else
+ emake LDFLAGS=-static || die "emake failed"
+ fi
+}
+
+src_install() {
+ einstall
+ if [ -z "`use build`" ]; then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}