summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.13.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.13.ebuild45
1 files changed, 17 insertions, 28 deletions
diff --git a/sys-devel/autoconf/autoconf-2.13.ebuild b/sys-devel/autoconf/autoconf-2.13.ebuild
index 12ffbb07c1b4..276261263b43 100644
--- a/sys-devel/autoconf/autoconf-2.13.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.24 2014/01/17 04:23:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.25 2015/03/19 23:49:17 vapier Exp $
+
+EAPI="5"
inherit eutils
@@ -19,24 +21,21 @@ DEPEND=">=sys-apps/texinfo-4.3
RDEPEND="${DEPEND}
>=sys-devel/autoconf-wrapper-13"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-destdir.patch
- epatch "${FILESDIR}"/${P}-test-fixes.patch #146592
- touch configure # make sure configure is newer than configure.in
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-destdir.patch
+ "${FILESDIR}"/${P}-test-fixes.patch #146592
+)
- rm -f standards.{texi,info} # binutils installs this infopage
+if [[ -z ${__EBLITS__} && -n ${FILESDIR} ]] ; then
+ source "${FILESDIR}"/eblits/main.eblit || die
+fi
+src_prepare() { eblit-run src_prepare ; }
+src_install() { eblit-run src_install ; }
- sed -i \
- -e 's|\* Autoconf:|\* Autoconf v2.1:|' \
- -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
- autoconf.texi \
- || die "sed failed"
-}
+src_configure() {
+ touch configure # make sure configure is newer than configure.in
-src_compile() {
# need to include --exec-prefix and --bindir or our
# DESTDIR patch will trigger sandbox hate :(
#
@@ -54,15 +53,5 @@ src_compile() {
econf \
--exec-prefix=/usr \
--bindir=/usr/bin \
- --program-suffix="-${PV}" \
- || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- dodoc AUTHORS NEWS README TODO ChangeLog ChangeLog.0 ChangeLog.1
-
- mv "${D}"/usr/share/info/autoconf{,-${PV}}.info
+ --program-suffix="-${PV}"
}