summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.4.1.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.4.1.ebuild b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
index b1aa9b39fc71..971db990c7a5 100644
--- a/sys-cluster/openmpi/openmpi-1.4.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.1 2010/01/20 02:24:37 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.2 2010/02/03 23:18:49 jsbronder Exp $
EAPI=2
inherit eutils multilib flag-o-matic toolchain-funcs fortran
@@ -57,6 +57,10 @@ src_prepare() {
echo 'oob_tcp_listen_mode = listen_thread' \
>> opal/etc/openmpi-mca-params.conf
fi
+
+ # https://svn.open-mpi.org/trac/ompi/ticket/2201
+ epatch "${FILESDIR}"/${P}-r22513.patch
+
}
src_configure() {
@@ -67,10 +71,6 @@ src_configure() {
--enable-orterun-prefix-by-default
--without-slurm"
- # Workaround for #288147 which also caused packages like hdf5 to fail.
- # http://www.open-mpi.org/community/lists/users/2009/12/11419.php
- c="${c} --includedir=$(mpi_root)usr/include/${PN}"
-
if use mpi-threads; then
myconf="${myconf}
--enable-mpi-threads