summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/quik/ChangeLog6
-rw-r--r--sys-boot/quik/files/headers.patch22
-rw-r--r--sys-boot/quik/quik-2.1.6.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-boot/quik/ChangeLog b/sys-boot/quik/ChangeLog
index 3ce45c8f491d..ba98121d4f9a 100644
--- a/sys-boot/quik/ChangeLog
+++ b/sys-boot/quik/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/quik
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/quik/ChangeLog,v 1.10 2006/11/27 21:58:35 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/quik/ChangeLog,v 1.11 2006/12/05 04:51:38 josejx Exp $
+
+ 05 Dec 2006; Joseph Jezak <josejx@gentoo.org> +files/headers.patch,
+ quik-2.1.6.ebuild:
+ Added patch to fix compiling with newer kernel headers.
27 Nov 2006; Joseph Jezak <josejx@gentoo.org> quik-2.1.6.ebuild:
Marked ppc stable.
diff --git a/sys-boot/quik/files/headers.patch b/sys-boot/quik/files/headers.patch
new file mode 100644
index 000000000000..1778b18f1b0f
--- /dev/null
+++ b/sys-boot/quik/files/headers.patch
@@ -0,0 +1,22 @@
+--- util/elfextract.c.bak 2006-12-04 23:08:33.000000000 -0500
++++ util/elfextract.c 2006-12-04 23:08:45.000000000 -0500
+@@ -6,7 +6,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #define __KERNEL__
+-#include <linux/elf.h>
++#include <elf.h>
+
+ FILE *fi, *fo;
+ char *ni, *no;
+--- second/quik.h.bak 2006-12-04 23:10:08.000000000 -0500
++++ second/quik.h 2006-12-04 23:10:12.000000000 -0500
+@@ -26,7 +26,7 @@
+ int tolower(int c);
+ int stricmp(const char *s1, const char *s2);
+ int strncmp(const char * cs,const char * ct,size_t count);
+-int strlen(const char *s1);
++// int strlen(const char *s1);
+ char *strcpy(char * dest,const char *src);
+ char *strncpy(char * dest,const char *src,size_t count);
+ char *strchr(const char * s, int c);
diff --git a/sys-boot/quik/quik-2.1.6.ebuild b/sys-boot/quik/quik-2.1.6.ebuild
index 6187c5ddc83b..447de6bbff2c 100644
--- a/sys-boot/quik/quik-2.1.6.ebuild
+++ b/sys-boot/quik/quik-2.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/quik/quik-2.1.6.ebuild,v 1.2 2006/11/27 21:58:35 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/quik/quik-2.1.6.ebuild,v 1.3 2006/12/05 04:51:38 josejx Exp $
inherit toolchain-funcs mount-boot eutils
@@ -31,6 +31,7 @@ src_unpack() {
cd ${WORKDIR}/quik-2.1
epatch ${WORKDIR}/quik_2.1-6.diff.gz
epatch ${FILESDIR}/md-fix.diff
+ epatch ${FILESDIR}/headers.patch
}
src_compile() {