summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild')
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild
new file mode 100644
index 000000000000..7020c2550ebf
--- /dev/null
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.14.ebuild,v 1.1 2008/01/04 01:10:17 ranger Exp $
+
+inherit eutils
+
+DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
+
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc64"
+IUSE="ibm"
+DEPEND="!sys-boot/yaboot
+ sys-apps/powerpc-utils"
+RDEPEND="!ibm? ( sys-fs/hfsutils )
+ !ibm? ( sys-fs/hfsplusutils )"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install() {
+ # don't blow away the user's old conf file
+ mv ${WORKDIR}/etc/yaboot.conf ${WORKDIR}/etc/yaboot.conf.unconfigured
+ cp -pPR ${WORKDIR}/* ${D}/
+}